Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

lr-fbalpha and neogeo.zip



  • Hi guys,

    I made an image a couple of months ago and had NeoGeo roms setup and the bios was in the root of the bios folder and it worked fine. Ive gone to make a new build today and tried the same and it doesn't work. The game snow only work if the bios is in the games folder and its correctly setup to use lr-fbalpha.

    Any ideas?



  • @mancity I don’t know your particular setup but I used mame2003 plus as my default arcade emulator but then needed to add games that were only available with/working with lr-fbalpha, and wanted to keep all ROMs in the arcade folder together rather than having a separate system. My guess is maybe you have the same issue which is why you don’t want to/can’t have the neogeo bios for FBA in the ROMs folder. For the number of FBA ROMs I was using (less than 20) I just took tbe neogeo bios for FBA, unzipped it into a temporary folder on my computer, opened the unzipped neogeo bios folder, copied the unzipped files, and pasted them into each FBA rom folder (example: into the metal slug 4 game zip folder) by dragging them over to that folder using samba shares. The way it seems to work is that if the bios is in the same zip folder as the rom itself it stops looking for the bios and plays the game. For me, FBA (or Mame2003 for that matter) never worked with the neogeo bios only in the general bios folder, it either had to be with the ROMs in the arcade directory (as my Mame2003 neogeo bios is) or in the particular Rom zip folder (as my FBA neogeo bios is).



  • Hmm thanks for your reply. So basically try putting a copy of the unzipped neogeo.zip inside the .zip of each game and try again? I'll give it a go tonight thank you :)



  • @mancity exactly. And it definitely works. (FYI, Based on a suggestion in another post, I also tried a similar concept for where only one version of an arcade rom works but it is not the base/parent version. I guess I had gotten what are called “split rom” sets. I was building a bartop arcade and didn’t want to have like 2 versions of, say, Marvel Superheroes, on the game list just to be able to play one. So I unzipped the parent rom folder (msh), took the unzipped contents, and pasted them into the zipped game folder for the working (clone/child) rom without unzipping that clone/child rom (which I think was mshu, but don’t quote me on that, it’s just an example for this post) and viola only one entry on the game list for Marvel Super Heroes and it now worked! So seems to work for whenever a particular game needs more files, whether that be a parent rom or bios files, to run.



  • Ok thank you I will try it tonight and update this.

    I cannot understand how i previously put the neogeo.zip in home/pi/retropie/bios and it worked fine, bu now does not though...


  • Global Moderator

    lr-fbalpha is constantly updated, and with software updates come romset updates.

    you may need the neogeo.zip from the latest FBA 0.2.97.44 romset.

    it's nothing to do with putting bios within the game zips...



  • @dankcushions but I have a working nepgeo.zip file because if I put it in the games directory the games work - just not if I put it into the bios directory?


  • Global Moderator

    @mancity oh, interesting. what version are you using of fbalpha? if you bring up the RGUI, it should have a version string at the bottom - efa0235 or something like that


  • Global Moderator

    actually, quickest way is to diagnose is to launch with verbose logging via runcommand, recreate the issue, and then paste the log from here: /dev/shm/runcommand.log



  • @dankcushions Ill have to have a look tonight - Is it worth updating the package?


  • Global Moderator

    @mancity i wouldn't. you could find you'll need to update your romset.



  • @dankcushions oh haha - what do you suggest then? I'll check the lr-fpalpha version when I get home. I assume you cane place the bios somewhere other than the games folder for pifba?


  • Global Moderator

    @mancity i suggest what i said above :) looking at the logs - it should show it finding out your system directory, and then say the file it can't find. that should tell us everything.

    pifba is a different emulator that needs a completely different romset. forget that.



  • Sorry I didnt see the log file reply - I will have a look alter and update this :)



  • Ok so I took a copy and then updated lr-fbalpha and it works with the neogeo.zip in the BIOS directory :)


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.