Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Monitor Flicker On/Off



  • I am running into a problem setting up my Arcade Cabinet. I am running a Dell 1908FPc Monitor, Raspberry Pi 3B+ with a Cana Kit Setup (2.5 Amp Power Supply) running the latest Retropie v4.4 it says on the download page, SanDisk Ultra 32GB microSDHC UHS-I card and Reyann Zero Delay LED USB Encoder, 8 way SANWA Joystick , LED Illuminated Push Buttons.

    I am using a DVI to HDMI converter for displaying purposes. First Tried VGA to HDMI but that didn't work. When I plug everything in it starts up and displays the default retropie logo, then emulation station, then it goes to my Game List Screen and the monitor just flickers on and off for a few seconds each time... and gives me a message "Cannot Display This Video Mode" "Optimum resolution 1280x1024" I tried to go into video settings on my retropie and changing it to 5:4 but that didn't help, really thought it would because thats the root issue... so the monitor says

    I have read through a ton of forums but definitive solutions were not presented... not sure what to do, it probably lies in my config.txt file but I cant ssh into that right now. If anyone has figured out how to fix the issues with Dell's 5:4 display please help! Thanks!!!!



  • @nasonjo I believe the display settings are controlled by the config.txt. if you can't ssh right now, you can plug the SD card directly into your computer to make changes. The boot directory is on a partition that windows can read.



  • @quicksilver once in is there a certain place I need to put the new text? Any idea what the required text I need is? I have pulled some lines from other posts but no answer to the 5:4 specific issue as far as I know. Some people figured it out but never posted their solution for the community to see.

    I’m not very good at code, etc. I only know the basics of html



  • @nasonjo try this, uncomment and change to:

    hdmi_group=2
    hdmi_mode=35

    edit:
    you may also need to make sure that hdmi_drive=1


  • Global Moderator

    @nasonjo If you put the SD card in your PC, the file should be there - config.txt. Modify it with notepad as @quicksilver said and add the lines he mentioned. The file has a simple <option>=<value> format, the lines starting with a # being comments, so it's easy to understand and modify.



  • @mitu @quicksilver thanks, that should be easy enough, I was trying to ssh and connect over server and couldnt find it because taking the sd card out of the pi case is such a pain.. I will try it when I get home from work! Any other sucessful suggestion is welcome until then, Thank you!!



  • @quicksilver is there something specific I need to uncomment? What would t look like if so.. or am I simply getting into the txt file and setting it up as:

    #hdmi_group=2
    #hdmi_mode=35
    #hdmi_drive=1



  • @nasonjo remove the # symbols (those symbols tell the computer to ignore those lines). That's what uncomment means.

    Edit: If there is already a line in the config.txt that has those settings listed, simply remove the # and change the value. If there is no line then add it in.



  • Understood! Thanks again, I'll give it a try!

    Edit: Just found the eLinux RPiconfig document you are referring to, very helpful. Hopefully this takes care of it.



  • @quicksilver unfortunately this didnt work...

    uncommented the 3 and changed the values to the above specified. Same error.



  • Switched back to VGA and uncommented 'hdmi_force_hotplug=1' and it seems to be working great! We will see how the sound is when I hook up the amp and speakers, thanks everyone for the advice! Really appreciate it!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.