Please do not post a support request without first reading and following the advice in

no input in retroarch and lr-cores

  • Hello!

    Story short: keyboard and gamepad work in EmulationStation. They don't work in RetroArch and in libretro cores (i.e. lr-pcsx-rearmed, lr- cores from main packages).

    My specs:
    Pi 3 B+, official power supply 5.1V
    RetroPie 4.4 built from - retropie-4.4-rpi2_rpi3.img.gz via Balena Etcher
    USB devices connected: Logitech K120 keyboard, ssd Samsung 850 evo via gembird EE2-U2S-41 sata to usb case
    Controller used: Logitech F310 usb, Redragon Titanium bluetooth

    I have bought Pi3, installed RetroPie img with First Installation guide here on Updated it. Also I plugged ssd, used guide Uploaded to ssd roms, bios for ps1, stuff. For cores only those in main packages were installed.

    EmulationStation successfully detected my Logitech F310 usb gamepad. With some problems I've connected Redragon Titanium gamepad via bluetooth, also recognized by EmuStation. All controllers work in EmuStation. But when I enter RetroArch through main menu -> RetroPie -> RetroArch or load any rom from nes, snes, ps1 no control device work, even keyboard. Have to killall via SSH from my pc.

    I've googled much info, guides, etc. Tried making individual config for ps1 in /opt/retropie/configs/psx/retroarch.cfg, getting info with jstest ( Didn't work.

    Eventually I've uninstalled lr-pcsx-rearmed and installed just pcsx-rearmed from optional packages. Edited /opt/retropie/configs/psx/pcsx/pcsx.cfg for both gamepads (though I couldn't bind dpad). And it worked! I can now play ps1 games.

    But of course I want to play nes, snes and just fix this problem.
    Please help, if you know solution.

    P.S. at some point my keyboard worked in RetroArch menu and in nes, but it wasn't my goal so I don't remember details.

  • Try deleting retroarch.cfg in /opt/retropie/configs/all and rename retroarch.cfg.rp-dist to just retroarch.cfg

    Then connect your pad and re map your buttons via emulationstation then try going into retroarch. If that doesnt work try mapping your pad again but leave the triggers out. I had issues where my triggers would mess everything up.

  • Deleting retroarch.cfg and renaming the other one didn't help. I reinstalled RetroPie with the same image. Installed plugin In it I've set detect by name and set Logitech to player1 and Redragon to player2. It worked for player1 in lr-pcsx-rearmed. Not for player2. It is a problem with Redragon gamepad I think.

    In plugin I've deleted 2nd gamepad and Logitech now works in all my cores and all my games and in RetroArch menu.

    But when I've tried games the very first time, I had only one gamepad (Logitech) and keyboard plugged. And they didn't work in games.

    I think it's the problem in RetroArch, that it decides on its own what controller to use for player. And you can't configure it easily.

    That plugin is a good solution with detect by name option, it sets the corresponding device for the corresponding player as you want it, not as RetroArch wants it.

    But to be sure I need to test it with normal gamepad for player2, not Redragon one.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.