Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Daphne gamelist.xml not being used



  • I'm having issues where all my retropie/emulationstation roms are being properly scraped and showing on my rpi3B+ except for Daphne.

    I can see the gamelist.xml was generated by Skyscraper (even tried deleting it and running again), it points to valid media files and they exist, yet in ES when I go to the Daphne menu the roms do not look like they've been scraped. It's as if it doesn't see the gamelist.xml.

    My gamelist.xml is located in /home/pi/RetroPie/roms/daphne

    Any ideas how to get the theme to pick it up?

    Thanks!!



  • @scampa123 Can you post your gamelist.xml to pastebin.com to take a look ?



  • @mitu Thank you!! I've put it here:

    https://pastebin.com/MejrYE1L

    Thanks again!

    I will say that the scraper sees multiple roms (lair2_314.zip, lair2_300.zip however ES only shows them as a single game...Not sure if that causes an issue, just thinking out loud...



  • The gamelist file seems ok, what exactly is not shown in Emulationstation ?

    will say that the scraper sees multiple roms (lair2_314.zip, lair2_300.zip)

    Since all .zip files resolve to Lair2 - Time warp, it's normal. You should keep just one.



  • @mitu I'm not seeing any of the artwork in ES for daphne. I'm using the COMICBOOK_4-3 theme (not sure if that matters) and all my emulators show the artwork, videos, marquis except daphne...

    IMG_0238.jpg

    Hopefully the photo helps!!

    Thanks again!



  • Well, the photo shows a different gamelist than the one you posted. It's clear Emulationstation doesn't use the gamelist.xml you posted.
    Check if \\retropie\configs\all\emulationstation\gamelists\daphne (file share folder) has a gamelist in it, if there is one, then rename it and restart Emulationstation. How did you install the Daphne emulator ?



  • @mitu

    Did you mean /opt/retropie/..../gamelists? If so, there is no daphne directory in there.

    I installed daphne from the retropie setup manage packages- manage optional packages

    Also, I setup last night running my ROMs off of usb using the retropie-mount director on the usb...if that helps...



  • Can you post the Emulationstation log, from ~/.emulationstation/es_log.txt, to pastebin.com ?



  • @mitu Here it is: https://pastebin.com/2jRbERnm

    Thanks again!!



  • There's an error regarding the daphne system in the log:

    lvl1: 	  Unknown platform for system "daphne" (platform "daphne" from list "daphne")
    

    which indicates your installation is out-of-date or you didn't install from the RetroPie image. What version of RetroPie are you running ?
    Please add more info about your system, as requested in https://retropie.org.uk/forum/topic/3/read-this-first.



  • @mitu

    I downloaded a new retropie image (prebuilt), but to get the specifics I ran ~/RetroPie-Setup
    git show to get to this:

    commit 3acd8a3add66c585cabf944fbefedcbf219a4001                                  
    Merge: 760e0810 a818b772                                                         
    Author: Jools Wills buzz@exotica.org.uk                                        
    Date:   Mon Dec 24 13:11:39 2018 +0000                                           
                                                                                     
        Merge pull request #2568 from psyke83/steamlink_depends                      
                                                                                     
        steamlink: update xorg dependency & reduce matchbox install

    https://github.com/RetroPie/RetroPie-Setup/commit/3acd8a3add66c585cabf944fbefedcbf219a4001


    RPI3B+
    Raspberrypi org power supply
    This is a Picade setup with a XHAT for wiring the buttons/joystick

    Is that sufficient info? Should I update somehow?



  • @scampa123 We don't support pre-built 3rd party images. Please use the image from retropie.org.uk/download.



  • @mitu That's is what I meant..It's the prebuilt retropie image. Could I just update it? Would it help?



  • @scampa123 I think I figured out why your gamelist is wrong - the Daphne system has .daphne as extension for game folders which interprets. So, while the gamelist is correct, Emulationstation will only look at the *.daphne folders from the rom/daphne system.



  • @mitu the daphne emulator expects those folders to be .daphne...I.e. lair.daphne



  • Is there a change I can make to fix this?



  • @scampa123 Modify the gamelist.xml and instead of the .zip file in the <path> node add your 'game.daphne` path. Restart ES and see if it works - try with 1 game first.



  • @mitu That did it!! I'll need to update the entries for the others..but I think this will work!! THANK YOU!!!


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.