Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Analog inputs for mame2003



  • I recently did a RetroPie 4.4 clean install, with the express purpose of “upgrading” from mame-mame4all to lr-mame2003. So, I’m using MAME 0.78 in place of MAME 0.37b5 ROM files.

    It works well, except I can’t get the analog stick to work for any of the games, nearly all of which are early 80s vintage arcade titles. I hit TAB to get to the MAME internal menu and try to change the directional input from the D pad to the left analog stick. I hit enter to change the value and then nothing happens when I move the stick. As soon as I hit a button D-pad, the selection gets made. I’ve done this both for general inputs and for specific titles and get the same result.

    I didn’t have this problem when I was using mame-mame4all. I gather this may have something to do with using an analog input, but I couldn’t find anything that would explain this difference in behavior between the two MAME implementations.

    Any advice?

    Thanks

    PS This is RetroPie 4.4 running on a Raspberry Pi 3 using a Logitech F710 wireless gamepad


  • Global Moderator

    Did you do any updates for the installed script and packages (specifically for lr-mame2003) after installing the image ?



  • @slimbrick To enable analog sticks in lr-mame2003, or any RetroArch emulator, you can use the configuration editor. More info at: https://retropie.org.uk/docs/Configuration-Editor/



  • mame2003-plus has just added another layer of analog input support. If you get mame2003 running but you find it's too limited on analog, I believe it's a relatively painless swap over to the Plus version in RetroPie.

    Because the new analog support in Plus is so new, there is no reason to jump over to Plus yet unless you feel you would like the added functionality. There may still be bug fixes for another week or two.

    That thread is here: https://retropie.org.uk/forum/topic/17766/mame2003-plus-hundreds-of-new-games-improved-input-features-new-bugs-now-with-runahead-support



  • @dudleydes Thanks, I didn't recall using the configuration editor previously to get the analog sticks to work. Works great now.

    One other question. The "Select" button inserts a quarter and "Start" starts the game. However, after I start a game, the "Select" button doesn't work. I basically hit a bunch of buttons on the joypad and then "Select" will work. That seems odd and wasn't the experience I had when I originally set this up.

    Any other advice on addressing this issue?



  • @slimbrick Could you give an example of a rom where pressing Select doesn't insert coin?



  • @dudleydes "Select" eventually inserts a coin for all roms. However, I have to push a bunch of buttons first before "Select" inserts a coin. I've experimented to see if I need only to wait a certain amount of time, or hit a certain button before Select, however I haven't found any specific requirement other than hitting a bunch of buttons. And this happens for all roms, mspacman.zip, frogger.zip, mappy.zip, dkong.zip, and so on.

    It's off topic but fun to mention-- I modified the dkong.zip ROM so that Pauline is the one climbing the ladders to save Mario rather than the other way around. It's pretty cool that it actually worked (i.e., I didn't figure out how to do it, but found a process for doing it on the web).



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.