Please do not post a support request without first reading and following the advice in

Problem facing in connecting the WiFi

  • Pi Model or other hardware: 3
    Power Supply used: official raspberry
    RetroPie Version Used: 4.4
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: 2TB HD flat32
    Controller used: Wiimote
    Guide used:

    Even tried the routerlogin website -

    WiFi worked without a problem the last 6 months. Yesterday, I did two things:

    I manually mounted a usb hard drive (see guide)
    I set up an additional wiimote controller (see guide) to my existing ps3 controller.
    Shortly afterwards I noticed that retropie->WiFi->connect to WiFi Network does not list the WiFi networks it should list. This is what it lists:

    H Hidden ESSID

    Both my home network and my iPhone hotspot (who are up and running) are not listed (as well as all the neighbours' stuff).

    I do not know whether this issue is related two the external hd mount or the wiimote setup.

    I have checked WiFi country and it is correctly set.

    Output of Show IP Adress is:

    Your IP is :

    Output of 'ip addr show':
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    2: eth0: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000

    Any idea how I get this back running?

  • Global Moderator

    Does it work if you disconnect the other devices ? Is the external disk powered from the PI or it has a separate power adapter ?

  • Banned

    you need to shutdown turn you pie off then set your network up with raspi-conf then it works again dont know why just does well for me anyway.

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.