Please do not post a support request without first reading and following the advice in

ps4 controller not working well ingame, but i can open gui with ps button

  • Hi!

    Some days ago i connected my ps4 controller via usb to my retropie raspberry 3 with emulationstation, well, it worked properly (the only thing was that Cross and Circle was swapped...) but yesterday i tried to play and controller is not working ingame on psx roms, i tried also with N64 rom and it worked well.

    I also tried with psx game Harry Potter 1 and in the language selector, i can change the flag language with D-pad but i cant press Cross, it doesnt reacts.

    I tried to reconfigure controller in ES, also i tried all in Retroarch (it permits me open GUI with "PS" button... but i close GUI and Cross, Square, Triangle and Circle dont work) but it doesnt change anything, i tried all, standard mode, analog, retropad, default...


    If necesary i can record a video.

  • Also i tried a retro usb gamepad and it doesnt seems to work neither

  • Global Moderator

    Please add the info requested in to your post.
    The controller configuration should be done in Emulationstation, it's then automatically translated into RetroArch configuration file(s) so you don't have to re-configure your controller in again in RetroArch.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.