Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

lr-Harari - Error installing from source



  • I was learning some Atari history (another bonus learned from the retro world of emulation) and I decided I wanted to give the Atari ST a try. I got the stand alone Hatari working, so now I really want to give the libretro version of Hatari a try to see if I can make any headway. I receive an error when trying to compile from source 01_libcapsimage.diff failed to apply Here is a pastbin link to the error log.

    Libretro Hatari git states:
    "New rebasing of Hatari based on Mercurial upstream. Tries to be a shallow fork for easy upstreaming later on."

    I'm not sure if that is anything new or even would have any impact.

    Power Supply used:  5V 3A UL Certified Compatible
    RetroPie Version Used (4.4):
    Built From: (Pre made SD Image on RetroPie website 
    retropie-4.4-rpi2_rpi3.img.gz)
    USB Devices connected:Logitech wireless keyboard/mouse combo
    Controller used:snes tata clone (wired)
    Error messages received: lr-hatari patch    /home/pi/RetroPie-Setup/scriptmodules/libretrocores/lr-hatari/01_libcapsimage.diff failed to apply
    

  • administrators

    @BiZzAr721 yeah - I will need to update the patch. Use the standalone emulator in the meantime (which I prefer).



  • FUTURE READERS: THIS PATCH IS NO LONGER NECESSARY AS IT IS ALREADY IN RETROPIE [2019-02-08]

    @BiZzAr721 can you try this patch?

    cd $HOME/RetroPie-Setup
    patch -p1 < <(wget https://github.com/hhromic/RetroPie-Setup/commit/c1a4943ee72dcd38bc816656ffc76afb23ca4ede.diff -qO-)
    

    And then try to recompile from source?
    Edit: make sure you are using an updated RetroPie-Setup script



  • @hhromic Thanks. I will try when I get home later this evening.

    UPDATE
    I followed your instructions and it compiled like a champ!



  • @BiZzAr721 good to hear! Did you try the core? does it run properly?
    Thanks for reporting!



  • @hhromic I can get to the main menu screens but no input is recognized - keyboard or joypad. I cannot even access RetroArch menu through HOTKEY + X or any thing else such as HOTKEY + START to exit. I can't do much more tonight but I will try to access core through RetroArch.

    EDIT Controller issue seems to be with retroarch in general. Doing a reset and will try again.



  • @hhromic The core is working. Poor controls, and finicky as expected from the research I've done before installing it, but working nonetheless. Thank you for the quick response in getting the core compiled.


  • administrators

    @BiZzAr721 have you tried the standalone emulator btw? I much prefer it due to the additional configurability. Not being critical of having a libretro core though. Always nice.



  • I seem to have better luck with the standalone emulator as you said. My main hope for lr-hatari was for the joypad config and easy exit. Unfortunately, controls need a bit of work. For example, when I enter hatari menu or on the STe desktop, the joypad sometimes will not control the mouse, but just entering RetroArch menu then exiting will correct it.

    Is the best/only way of exiting hatari pressing F12, and navigating to quit?

    I will keep an eye on lr-hatari progress, and for now stick with the standalone Hatari. I will still experiment with lr-hatari but until it is more integrated I think it is at a plateau.



  • @BiZzAr721 thanks for confirming it working! @BuZz I'll send the PR to fix the build now.



  • I've tried to apply this patch by following the instructions here but was told that "Reversed or previously applied patch detected" -> Apply Anyway? > yes > 1 out of 1 hunk ignored.
    Tried to install from source after this and as per usual got the "Could not successfully build lr-hatari - Atari emulator - Hatari port for libretro (/home/pi/RetroPie-Setup/tmp/build/lr-hatari/hatari_libretro.so not found)."

    Any idea what am I doing wrong?



  • @youxia as the previous message said, the patch is already applied now in RetroPie (as you found out in your error message) and therefore you don't need to re-apply it again.

    Because we don't know in which state your RetroPie-Setup installation, I suggest you to revert its state with the following commands:

    git -C $HOME/RetroPie-Setup fetch -p
    git -C $HOME/RetroPie-Setup reset --hard
    

    After that, try to reinstall lr-hatari from source. I just tried it and is building fine.



  • Thank you @hhromic, it works now. I prefer the lr because RA has better scaling options for CRTs and also for some reason my Dualshock caused the Hatari menu to go crazy in standalone, works fine here.



  • I see lr-hatari can load an .m3u to allow disc control from retroarch. It will be automatically read from an uncompressed zip along with disk images.

    Edit
    It won't work within a zip, but works great loading directly from an m3u. Also, the disk image extension cannot be changed (eg. .disk1).

    I changed the disk extension to uppercase and removed it from es_systems.cfg

    I suppose you could use a hidden folder as well.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.