Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Issues with Autostart to Raspbian



  • First, some required information. I'm running RetroPie on top of Raspbian with the latest updates installed on a Raspberry Pi3b+. RetroPie version is 4.4. I am using the CanaKit 5V power supply. No overclocking or any mods of any sort. I have a USB mouse and keyboard combo connected - a Logitech one - uncertain of the model. I managed to get my SN30 8bitdo controller to pair with EmulationStation, and fixed my core issue that was my fault. But now, it seems when I got to the configuration script in ~/RetroPie-Setup/retropie_setup.sh, I cannot configure RetroPie to boot Raspbian to the desktop without it crapping out on login. I thought this was because I have a custom password set for my RPI. But it wasn't. I first attempted to login from GUI with automatic login and it dumped me back to the console. Same happened when doing GUI login with a password prompt, so it's definitely not because I have a custom password. Is this a potential bug? And if so, has it been reported yet?


  • Global Moderator

    @MikeRL Try disabling the autostart splashscreen script first: https://retropie.org.uk/docs/FAQ/#how-do-i-boot-to-the-desktop-or-kodi.



  • How do I remove the splash screen? Don't see anything there unless I'm missing something. The options I see only apply to the original Raspberry Pi - not the 3B+ I'm using.



  • Think I figured it out. Disabled the splash through Emulation Station. Didn't realize it was in there, thought it was changed in the config script for RetroPie. Now everything works.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.