Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Freezing after inactivity + audio issue



  • I´m new to this. running Retropie/Emulationstation from a Raspberry Pi 3B+ and whenever I leave it untouched for a while (10 min or so), I can´t "Wake it up" from the screensaver. Screensaver will still be working fine (changing images) but it won´t respons to any controls. Screensaver is only images, no video.
    This happens both if I manually enter the screensaver or not. Note that this only happens sometimes, not all the time.
    Ideas on what it could be? I have enabled SSH but haven´t yet tried to connect to it when this happens. Assume that ssh will be working next time this happens (putty), what should I be looking for?

    Also, Another problem is the audio. I use the 3.5mm audio output on the Pi, connected to a cheap 2-channel amplifier. This works fine, but sometimes when going through the menus the audio will suddenly stop working and won´t come on again until the Pi is rebooted. It seems to be random and not when I select a specific game in the menu.
    Ideas?


  • Global Moderator

    Can you please add more info about your system, as requested in https://retropie.org.uk/forum/topic/3/read-this-first ?
    How are you trying to wake up the system - keyboard, controller, etc ? If you're running a screensaver, consider disabling the power saving option in ES.

    For the audio part, try adding audio_pwm_mode=2 to your /boot/config.txt and see if it improves the sound cutting part.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.