Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Gameboy Color emulator causing raspberry pi to reboot



  • I have only had this happen in the GBC emulator lr-gambatte. I have tested with a few different ROMs and in all cases after approximately 10 minutes the entire raspberry pi reboots completely without any warning.

    I have also tested the gameboy advance emulator and I have played several games for 30 mins to and hour and have yet to experience the same reboot issue so my feeling is that this is related to the emulator somehow.

    I have looked for logs related to the issue and cannot find anything relevant, although I am a relative novice at this so I may be missing something. /dev/shm/runcommand.log does not exist on my pi so I assume no logs have occurred because everything is just hard crashing or something. I have also experimented with power supplies. I have used one 5v 2.5A brick which I got in a kit with the pi and have also tried a 5.25v 2A phone charger, and the issue occurs with both.

    Please let me know if I can provide any additional information which might be helpful.

    Pi Model or other hardware: Pi 2B
    Power Supply used: 5v 2.5A or 5.25v 2A
    RetroPie Version Used: 4.14.79-v7+
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: Powered USB hub w/ wifi dongle, bluetooth dongle, keyboard dongle, USB monitor
    Controller used: PS3
    Error messages received: None
    Log found in /dev/shm/runcommand.log (if relevant): None
    Emulator: lr-gambatte



  • @majellin said in Gameboy Color emulator causing raspberry pi to reboot:

    /dev/shm/runcommand.log does not exist on my pi so I assume no logs have occurred because everything is just hard crashing or something.

    /dev/shm/runcommand.log only exists in RAM, if your system is shutdown/rebooted, it won't be there. Are you using any overclock settings ? Do you get any undervoltage flash signals on your display ?



  • @mitu thanks for the reply. I am not using any overclocking and I get no warning of any kind on the display before this occurs.



  • @majellin Have you tried updating lr-gambatte?



  • @quicksilver yes, I have run the update all command through the retropie setup GUI (if there is a different way, please let me know but I saw lr-gambatte get updated as part of that process)



  • @majellin Its usually best to update emulators as needed individually as updating everything can add changes that you may not necessarily want.

    To update individual emulators: first update retropie-setup script then go to manage packages. Lr-gambatte is probably under main packages, from there try updating from source. (You've already tried the binary version when you updated all)



  • @quicksilver sorry for the delay. I finally got a chance to try updating from source and the issue persists.



  • @majellin I'll see if I can replicate the issue



  • @majellin so ive been running a game now for 20 minutes with no problems. Was there a specific game causing issues? What brand is your power supply?



  • @quicksilver I tried a few games all with the same result after 15-30 mins. I have tried a samsung phone charger and also the canakit power supply which came with the pi. I have a hard time imagining this is a power issue since I have yet to have any issues with the gameboy advance emulator but I am happy to try anything you think might help.



  • @majellin Just for the record, I had freezes in PCSX-reARMed due to a sub-par power supply despite not having undervoltage warnings. So this may still be worth a try.



  • @majellin yes lr-gambatte should be pretty low impact I agree. Do you have a spare SD card that you can try a game on a stock retropie image? Might help to figure out if it's a software or hardware issue.

    Edit: I should add that the canakit power supplies are notorious for their unreliability.



  • @quicksilver I'm not sure what you mean about the stock retropie image. To the best of my knowledge thats what I am already using but feel free to correct me.

    I am happy to try a different power supply but maybe you could recommend a good one since I have tried the only two i have access to currently and it would be unfortunate if I purchased another notoriously bad one unwittingly



  • @majellin I am assuming you have made other changes to your retropie setup? Changed the theme, added new emulators, updated anything? If so you are not on a stock image. A stock image is one that has not had ANY changes (this is important for troubleshooting).

    I'm not saying that this is the culprit but we should try to narrow down if it's hardware or software.



  • @quicksilver I see. I'm pretty sure that I saw this occur before trying to update anything and i have not changed any themes but I can give a stock image a try in case I am wrong. Would like to still get a new power supply ordered though if you have a recommendation. Thanks for all the suggestions so far





Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.