Please do not post a support request without first reading and following the advice in

Help with install of Amiberry/WHDLoad

  • I've spent the last 4 hours trying to get this to work... based on what should be a total no-brainer.

    It seems the latest build of Amiberry I pulled down tonight doesn't like my Retropie 4.4 setup, but the previous version seemed ok. Now all I get is "WHDLoad failed returncode 10". No matter what .lha game I try, or where I download it from. I have tried .lha files from the proper/reccomended Retroplay list as well....returncode 10. I checked all my kickstart ROMs and made sure I have the correct versions... returncode 10. I completely removed Aimberry and reloaded... returncode 10. That's all I get... returncode 10, no matter what I do. Is there some error log, or something I can look at to tell me what I am missing? I checked to make sure the paths for the files are correct. I've done everything I could possible to get this working.

    Any help/advice to get me going again? If I am on the wrong forum for this, where should I be posting this?

    Thanks in advance,


  • @jamrom2 It may be related to this issue regarding Amiberry updates for RetroPie. Could you try installing from binary if you have not already done so?

    A similar issue seems to have been reported at the Amiberry Github page. If installing from binary does not fix it, then I would suggest posting your issue at the Amiberry Github, unless that was you who opened the ticket.

    To help the devs, could you post as much information as you can so that they can replicate the problem. I feel the following would be a minimum:

    • Raspberry Pi model
    • Which version of Amiberry you are using? Whether Amiberry was installed in RetroPie by binary or source?
    • An example of a .lha file, with full file name, that produces this error. What is the file size of your .lha files? They should be 1-3 MB. If they are 50-100kB, then these are the installer files which do not include any game data.
    • A screenshot of the error code. Amiberry does create debug reports in /opt/retropie/configs/amiga/amiberry/whdboot/save-data/Debugs/ so you could include anything from there.

  • @dudleydes Ok, I'll do this. Thank you for the reply and Sorry for the lack of info, it was after 3am in NY and I was out of gas, out of coffee and out of eyesight... lol.

    • Raspberry Pi3+
    • It's the latest build of Amiberry (2.25), based on the 4.4.8 setup script in Retopie
    • Archon_v1.2_NTSC_0914.lha - 432KB. I used these same .lha files in my previous version of amiberry, and they worked. With this new version, nothing I have works. Even pulling down new .lha packages from Retroplay fails.
    • there is nothing in the folder you mention. I have it there, but it is empty other than a .txt file called 'foo.txt'

    A screen shot will yield nothing other than a grey with blue border Amiga style workbench screen with the following in the upper left corner.

    AMIGA ROM Operating System and Libraries
    Copyright 1985-1992 Commodore Amiga, Inc.
    All rights reserved
    WHDLoad: Unknown command
    WHDLoad failed returncode 10

    Not much else I have to offer which is why it's so frustrating. I will remove this version as I loaded it from Source and load it again from Binary, then get back to you.


  • @dudleydes

    Just tried the Binary version... same result. So I'll head over to the devs site and post the issue there. Nothing seems to work with this new version. Everything was fine before I updated other than my controls not being auto-recognized and that it would not load .adf files.

    I'd rather that than what I am getting now, which is nothing... but my controller and mouse auto-detect and work now. Go figure.

  • Well... this seems to be the temporary fix... finally! Works good for me on the latest build. Just do what the user AnalogHero recommends at the bottom of the thread and it will load as it should.


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.