Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

LR-PPSSPP per game GUI control remapping - analog stick



  • Hi, so I searched the forum tags for psp and lr-ppspp and reviewed the retropie docs page for psp and retroarch configuration but am still stuck. A few PSP games require analog input from the PSP stick. (Specifically I am trying to move my character in WWE All Stars and pull the pinball plunger in Williams Pinball classic). On my retropie setup where I have a knock off usb PlayStation controller connected it properly recognizes the dpad as the psp dpad and the left analog stick as the psp stick. On my bartop (raspberry pi 3b+, retropie 4.4 also) I only have one joystick (Xin mo) to work with. Some psp games work fine so I don’t want to mess with overall config files, just remap using the RetroArch GUI remapping and save the game config for these couple of games. For those games I want my joystick recognized as the analog stick for the PSP rather than the dpad. Can someone help me figure out what I need to change in the remapping GUI to do this? I need to use the Lr-ppsspp emulator because the standalone backs out to a general PSP user interface when you exit a game and I don’t want that clutter on my bartop. And, BTW, for what it’s worth similar to what we recently found for Reicast, with the proper settings lr-ppsspp installed from source works very well (for the same games that work very well with stand-alone, which is not most psp games, of course).



  • @BJRetro ok so I figured this out on my own eventually so posting in case anyone else has this issue in the future putting lr-ppsspp on a bartop where you only have one joystick to work with.

    1-go to retroarch GUI menu from the psp game you want to change controls for
    2-go to controls
    3-keep type of control as retropad not retropad with analog
    4-if like me your joystick is loaded automatically as the psp digital game pad but for the game you need it recognized as analog, scroll down to where the entries begin with “auto” and where it is referencing the dpad up down left right
    5-change those auto entries by clicking on them until they refer to analog up (y-), analog down (y+), analog right (x+), analog left (x-).
    6-then select the option for saving the game control config
    7-back out, go to the overrides menu and select “save game override”

    Now I can play williams pinball and wwe all stars on my bartop yay! Only issue is I still couldn’t play angry birds because now while I could pull the pulley, it wasn’t true analog functionality where you can pull back just a little. But happy to get the rest working and hope this helps someone else if they plan to use lr-ppsspp on a bartop!!



  • You can map the menu button in standalone PPSSPP, I meant you can map the exit emulator button. Nevermind, I must have imagined it, or it was in a different distribution.
    There might still be another way to exit.



  • Hey have you tried Pangya Fantasy Golf? It is disable software skinning 60fps. Except loadscreen transitions. Actually golf scares me, but this game isn't very scary, maybe I can get over my fears.

    Other than Bob, he's kinda scary. Yeah nevermind no golf for me.



  • @Efriim no I haven’t tried that game. Thanks for finding the forum post about standalone psp exiting back to emulation station rather than the psp menu. Good to know since that was my main issue using standalone. Using the retroarch version now seems like a more viable option than it was before in terms of performance based on my testing and it is nice to have the GUI. But i will try this out on my experimental setup to try to confirm it works.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.