Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Some games not loading a save file



  • Apologies in advance if I mess up anything here. I'm a complete rookie to RetroPie and the Raspberry Pi as a whole. I never usually try to find help on ANY sort of forum unless I'm completely stumped and out of options. Please excuse excessive detail, I absolutely hate it when people don't explain their problems clearly.

    I'm using:
    Pi Model 3 B+
    RetroPie Version 4.4

    I was playing Chrono Trigger on SNES for about an hour and saved the game before exiting using the SELECT+START combination to return to ES. Later I decide to boot it up again, only to find that the game boots to the default "New Game" screen instead, when it should boot to a screen that'll let me load an existing game. When I was playing Metal Gear Solid on Playstation earlier today, the game crashed after exiting a cutscene. I boot the game again, go to "Load Game", but the game says there's no file on the memory card. In both of these games, I KNOW I saved using the in-game system. I looked at the files in the ROMS folder on the Pi, and it shows that both games do have a .srm file in their respective directories. The weird part is that all of my other games (that have a save file) work fine, and I can load a save profile no problem. I tried one user's solution of renaming the .srm file to .sav, but to the same results as earlier. I tried another solution of resetting permissions, again to nothing.

    As far as I know, no one else has had this exact problem. I didn't really care about Chrono Trigger, but I lost 3 hours of gameplay on that MGS crash. If this is gonna be a pattern with future games, then I need to fix it. If there's anything you need to know, or need me to be clearer on something, then let me know. Thanks in advance.


  • Global Moderator

    @shmonroe The .srm file is written to the disk when the emulator exits, but if the emulator crashes, then the file is not written. This is the default setting in RetroArch.
    If you'd like to periodically save the .srm contents to the disk, use the autosave_interval option in /opt/retropie/configs/all/retroarch.cfg and set it to an appropriate interval (like 5 minutes). This will ensure the .srm file is written to disk periodically instead of being kept in emulator's memory and written at exit.



  • @mitu

    Thank you. I saw that as a solution on a couple other threads, and that was going to be my next course of action to prevent something like this happening again (if possible), but I wanted to make sure that my existing save files couldn't be salvaged. Looks like not, so I'll just have to treat the loss as a learning experience.



  • @shmonroe
    If you're playing European(Pal) on easy and not for zero retries, zero kills, zero time caught. Save file is right after sniper wolf.
    You can use Memcardrex to check if there is anything in the srm, that is in the link too, but there probably isn't anything there.
    Emulator closing would sometimes happen when I didn't have enough gpu memory, but I can't say for certain if it would help, the Gpu memory split option is entered from raspi-config advanced settings.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.