Please do not post a support request without first reading and following the advice in

Multiple Sixaxis problem

  • Hello,

    I have 4 fake PS3 controllers which pair with the retropie ps3 driver to my laptop with a bluetooth dongle perfectly on ubuntu 18.04. The problem is however, that only max. two of them can connect at the same time. Only one time all four controllers connected properly and I did nothing different than the normal pairing process I always do...

    It would be nice to be able to play with all four of them simultaneously.
    Has anyone an idea what could cause that problem/what I can do about this?

    Thanks for your help ;)

  • Global Moderator

    @weaster007 Uninstall the ps3controller driver and use the sixaxis driver for the PS3 controllers. Give it a try and see if it works, it should be using a more recent driver - make sure you pair them individually (again) after installing the driver.

  • If you mean Qtsixa I have now tried 2 hours to get it working with this but with this no controller connects. I think it is because they are Shanwan clones..
    I just can not understand why I can't connect 4 at the same time when all of them work alone. I tried different Bluetooth dongles and even different laptops now.

    Well, thanks for your help anyway. Maybe some day this will work.

  • Global Moderator

    @weaster007 No, I don't mean qtsixa, I mean the sixaxis driver package in the RetroPie Setup script


    'sixaxis' : Helper service to install & configure the latest drivers for official and third-party DualShock controllers (ps3controller replacement)

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.