Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Best Tomb Raider on Raspberry Pi



  • Hi, What are the best ways to play Tomb Raider on the Raspberry Pi? Any system, any version of the game. I have Tomb Raider for the PS1 (four roms) but they all lock up after the game menu or freeze during the game. My Pi is a 3B+ with no overclocking. I don't plan to overclock at this time.

    I heard the Saturn version (which is inferior to the PS1 version) does not play well on the Pi, is that right? How easy is it to set up the game on Dosbox? Will it play in 640x480 resolution? I also have, but can't get to work, Dreamcast versions of Tomb Raider 4 and 5.

    Thanks



  • @George-Spiggott I only have experience with PS1 versions. I haven't noticed any freeze issues yet. You might want to try a different rom / different region.
    Saturn is not an option, as it is very difficult to emulate.



  • @George-Spiggott If you are feeling adventurous, then you could try OpenLara, an open-source engine.

    I experimented with it a few months ago, posting instructions of how I did at the sub-reddit. There is a newer version available since that post, which you should be able to download with the command:

    wget https://github.com/XProger/OpenLara/releases/download/latest/OpenLara_rpi.zip
    

    IIRC it was playable but the controls were a bit wonky though I can't recall exactly how. Some of the buttons weren't mapped correctly, I think.

    There is a RetroArch version also available which should fix any controller issues but, according to the libretro docs requires OpenGL, which would make it incompatible with RetroPie. Fortunately there was a pull request merged last month which fixed building on GLES platforms such as the Pi, opening up the possibility of adding lr-OpenLara to retropie.



  • @BobHarris Which PS1 version/region do you run on yours? Not sure of the region on mine but it is the version with no trailers for games at the beginning that runs best.

    @dudleydes Openlara looks interesting. I will definitely take a look at it.



  • I'm currently playing through USA version 1.1 bin/cue, lr-pcsx, it all works fine.
    Enhanced resolution mode works really well, it's just like playing the dos version.
    You must have some problem with your set-up.
    Other ps1 games working ok? Bios copied over correctly?



  • @pi2user Yep my other games work fine. I think I have the USA 1.1 version. It has adverts for Gex and a bunch of other games on one of the intro screens right?



  • @pi2user I found a 1.6 US version (chicken run demo) that works fine. It's quite a few .bin files. Does anyone know how to convert multi .bin games to a single .php?

    It does look pretty with enhanced resolution, it really does benefit from the boost.


  • Global Moderator



  • @George-Spiggott No, the first version to come with a demo was 1.2 USA. You see what's going on with all the versions here. tcrf
    At what point did it crash for you?



  • Thanks @Mitu. I should have been clearer, this Tomb Raider ROM has 57 .bin files. I've used that method before to make a two disk game with two .bin files one file (Metal Gear Solid) but that didn't work for this. I followed this video

    to combine my .bin files then ran it through PSX2PSP. I'll give the game a test later tonight.

    @pi2user When the wolves attack you just after the first save point. It doesn't crash per se, it just locks up. I can still exit the game with the hotkey combo. The new version I have doesn't lock up at all (so far).



  • @George-Spiggott I created PBP images of Tomb Raider 1, 2, Revelations and Chronicles from my own original copies of the PSX games and they all run perfectly fine on my Raspberry Pi. I used Imgburn to create BIN/CUE files and then used PSX2PSP to then create the much more handy PBP versions of the games.



  • I've tested my new ROM ,which I converted to PBP, and it works fine with no lockups. My next project will be trying to get the DC version of Revelations and Chronicles working.



  • I had a little experiment with my 1.0 Tomb Raider ROM. I always thought it was odd/impressive how small the file was and while play-testing the 1.6 file I noticed that music played in exactly the same places where the 1.0 file locked up. So I merged the 1.0 .bin file with the other 56 1.6 .bin music files into one big .bin file (effectively replacing the 1.6 game .bin file with the 1.0 one) then converted it to a .pbp file.

    The 1.0 version now works fine without locking up. It seems that whoever created the 1.0 ROM simply discarded the extra .bin music files for some reason and the game was locking up when the game looked for them.

    Problem solved.



  • I am running the 1.6 US version and it always freezes when standing in front of the lock for the door to the temple in the City of Vilcabamba. I have checked it 3 times and each time I stand in front of the lock all movement stops. I can press the Select and Start buttons and the emulator returns to the Playstation game list. Any thoughts?

    Running on a Pi 3



  • @HarleyDude This bit? 00:01 on the video

    I'm running 1.0 and it gets past there just fine. How big is your file(s)? Are you missing music .bin files?



  • @George-Spiggott How did you manage to solve the problem. I've got 'Tomb Raider (USA) (v1.6)' with the 57 bin file tracks but I'm confused as to how you fixed it as I'm having the same problem



  • @deanlv If you have all the files I'm not sure. My problem was I was missing the .bin (music) files.



  • There are also a couple GBA titles to check out.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.