Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Ubuntu Retro Support Please



  • Ubuntu 16.04
    i3-2120T Intel Core with Integrated graphics.
    Retropie latest wiki ref.

    I just now read that Ubuntu prior 18.04 is supported no longer. Of course, I wasn't being picky I just thought 16.04 was the prime.
    I guess I'll just upgrade...

    Linking this with this as it is probably opengl support.
    https://retropie.org.uk/forum/topic/21793/ubuntu-18-04-reicast-not-launching-games/17

    Retropie error in reicast

    Config dir is: /home/oem/.reicast/
    Data dir is:   /home/oem/.reicast/
    Personality: 00000000
    Updated personality: 00000000
    Linux paging: 4096 00001000 00000FFF
    MAP 00800000 w/ 25165824
    MAP 20000000 w/ 25165824
    MAP 04000000 w/ 16777216
    MAP 06000000 w/ 16777216
    MAP 0C000000 w/ 0
    vmem reserve: base: 4CDC0000, aram: 6cdc0000, vram: 50DC0000, ram: 58DC0000
    Mem alloc successful!
    
    Found 12 matching FB configs.
    Chosen visual ID = 0x21
    X Error of failed request:  GLXBadFBConfig
      Major opcode of failed request:  155 (GLX)
      Minor opcode of failed request:  34 ()
      Serial number of failed request:  35
      Current serial number in output stream:  34
    

  • Global Moderator

    @Efriim said in Ubuntu Retro Support Please:

    Does anyone know what I was missing to sucessfully install ES? As I said it works, it just says that the install failed.

    It's probably because the new Emulationstation needs the rapidjson-dev package installed - similar to Debian and Raspbian Jessie: https://retropie.org.uk/forum/topic/20613/.



  • @mitu I read that reicast was working in 16.04. If I just needed to install the libboost* & rapidjson-dev packages, I think I will reinstall to 16.04. Thanks mitu.

    And it is pretty great, I like it a lot. Now I'd like to find out how to configure it to start like raspberry pi into ES and exit to bash.



  • lr-redream and lr-reicast are functioning neither(18.04). Reicast installed from snap gives error:

    ERROR: ld.so: object 'libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (failed to map segment from shared object): ignored.
    


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.