Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retropie overwriting



  • Hello. Maybe is a fool question but I have two memories sd with different versions of retropie. One has the latest retropie and the other one an old one. My question is in the old one I copy just the new version directory RetropieSetup, where is located the retropie setup script, then run that script of retropie setup and then go to updated script and basic install in that retropie setup. This would update/install to the new version the old one? This is: In old version memory copy retropie setup script and directory, then execute that new retropie setup script and everything will be updated without destroy configurations, roms, etc.?


  • Global Moderator

    @ray3d Update your RetroPie packages on the old one, this would update the script and the packages, you don't need to copy them from the new installation. Or just clone the updated image and write it on the old image altogether.



  • @ray3d Try it. Why not use the retropie_setup that is already existing to update? or is your goal to have the old versions on the new retropie?



  • @mitu If I copy the latest retropie_setup in the old one and run it will update everything ok? Without destroy corning’s right? After so long I almost ready to configure my final station. If you remember I left a topic about the gamepad right buttons did not work because the disaster happened and I cannot run yet a stable station. I hope soon finish hehe.

    @Efriim Exactly is what I want to do retropie_setup as I said to @mitu It means copy the retropie_setup to the old one and run from there. If I run then the new version of retropie_setup in the old one will update packages and all. Is what I want !


  • Global Moderator

    @ray3d If you're on your odroid and the old one is using the ORA repository, then just rename the existing RetroPie-Setup folder and clone the latest RetroPie-Setup script version

    cd
    sudo apt install git
    git clone --depth=1 https://github.com/RetroPie/RetroPie-Setup.git
    

    You'll have the latest version of the script and then you can run the update from there. Note that this is not 100% guaranteed to work, since the previous version used another repo, but you can give it a try.



  • I did that nd unfortunately I have these errors when I try to execute emulationstation.

    https://imgshare.io/image/HDJO1

    https://imgshare.io/image/H2vGI

    What I do now. What I did was go to retropie setup then update script, then basic install and not worked. Then I went to packages and I removed emulationstation and reinstalled again nothing. Also I went to manage package cores and install all from source and nothing. What could be the problem now?



  • This is the log:

    lvl2: 	EmulationStation - v2.8.2rp, built Apr  3 2019 - 23:30:27
    lvl2: 	Parsing XML file "/opt/retropie/supplementary/emulationstation/resources/mamenames.xml"...
    lvl2: 	Parsing XML file "/opt/retropie/supplementary/emulationstation/resources/mamebioses.xml"...
    lvl2: 	Parsing XML file "/opt/retropie/supplementary/emulationstation/resources/mamedevices.xml"...
    lvl2: 	Creating surface...
    lvl2: 	Created window successfully.
    lvl2: 	Checking available OpenGL extensions...
    lvl2: 	 ARB_texture_non_power_of_two: MISSING
    lvl2: 	Loading system config file /home/pigaming/.emulationstation/es_systems.cfg...
    lvl0: 	Could not parse es_systems.cfg file!
    lvl0: 	No document element found
    lvl0: 	Error while parsing systems configuration file!
    

  • Global Moderator

    @ray3d This looks like a problem with your es_systems.cfg file - /home/pigaming/.emulationstation/es_systems.cfg. Can you post its contents on pastebin.com ? From the error it looks like it's empty - if that's the case, then remove the file and re-try starting Emulationstation.



  • It was a mistake of me this is solved. What happened was that at morning when emulationstation was not reinstalled with everything the odroid rebooted and rebooted in a nightmare and I could not enter to the system, nor the SSH. Then I removed the memory sd to insert in a PC and with DiskGenius, where one can access linux partitions, write, delete, etc., then I renamed there the emulationstation directory and with that I avoided the endless rebooting and I gained control of the system because emulationstation was the cause of the rebooting. Then I made the updates and all but the directory stayed bad renamed. And that is why the .cfg error appeared. The strange is that retropie setup never fixed that nor attempted to install or create a new directory with everything, if not directory was there (because it was renamed). Anyway I renamed to .emulationstation again, I made the updates of retro pie setup and is running perfect now.

    Now emulationstation after so long is working. I see the platforms and roms. However, none of them work. For example when I try to open a rom (Amiga with Amiberry for example), then I see these errors:

    https://ibb.co/WPzg3j5

    https://ibb.co/2kJzqp6

    That line 363 of the error in the picture is:

    local status=($(fbset | tr -s '\n'))
    

    After the errors of the photos it returns to the point of the system you were and sometimes can end in a crash or reboot (rarely but happens). Like that with any platform. How can be fixed the errors of the photos now to be able to execute the roms? Is the last step, every gun is there, now that is what happens.


  • Global Moderator

    Looks like fbset is not installed - try installing the package with apt install fbset and see if the games start.



  • Ok I will try but also check one photo and it says also, besides that, Audio Manager error ALSA, something like that, SDL audio problems. With that fbset can be fixed also?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.