Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • So I've recently purchased a used PS1 classic for $20. I mainly bought it for the classic ps1 usb controllers. I have retropie installed on Ubuntu 18.04 on my laptop. I figured that it would just be plug and play like most usb controllers. Turns out Retropie doesnt recognize it. I did 'lsusb - v' just to make sure that Ubuntu recognized it and it did. I literately did this for just a few minutes so I havent done much troubleshooting. I was just wondering if I was missing something obvious like a missing depedency or package that needs to be installed.

    Output of 'lsusb -v' for the controller:

    Bus 002 Device 007: ID 054c:0cda Sony Corp.
    Couldn't open device, some information will be missing
    Device Descriptor:
    bLength 18
    bDescriptorType 1
    bcdUSB 2.00
    bDeviceClass 0 (Defined at Interface level)
    bDeviceSubClass 0
    bDeviceProtocol 0
    bMaxPacketSize0 64
    idVendor 0x054c Sony Corp.
    idProduct 0x0cda
    bcdDevice 1.00
    iManufacturer 1
    iProduct 2
    iSerial 0
    bNumConfigurations 1
    Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 34
    bNumInterfaces 1
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xa0
    (Bus Powered)
    Remote Wakeup
    MaxPower 100mA
    Interface Descriptor:
    bLength 9
    bDescriptorType 4
    bInterfaceNumber 0
    bAlternateSetting 0
    bNumEndpoints 1
    bInterfaceClass 3 Human Interface Device
    bInterfaceSubClass 0 No Subclass
    bInterfaceProtocol 0 None
    iInterface 0
    HID Device Descriptor:
    bLength 9
    bDescriptorType 33
    bcdHID 1.11
    bCountryCode 0 Not supported
    bNumDescriptors 1
    bDescriptorType 34 Report
    wDescriptorLength 49
    Report Descriptors:
    ** UNAVAILABLE **
    Endpoint Descriptor:
    bLength 7
    bDescriptorType 5
    bEndpointAddress 0x86 EP 6 IN
    bmAttributes 3
    Transfer Type Interrupt
    Synch Type None
    Usage Type Data
    wMaxPacketSize 0x0040 1x 64 bytes
    bInterval


  • @polygonman244 did you try to program it in emulationstation as you need to to get it to work? The controllers work fine for me.


  • @edmaul69 Usually it will prompt me to program a controller, would i be able to manually map it in retropie config?


  • Nevermind, I just used the 'map controller' setting and it worked. I feel really dumb right now


  • @polygonman244 if you have mapped a keyboard in emulationstation it will never ask again for you to configure a controller.


  • @polygonman244 Hey, there. I know this goes back a year, but emulationstation does not detect my PS Classic controller on the latest version of Retropie on a Pi4 ("no gamepad detected" after boot) and I'm just hoping you can please elaborate on what you meant by "I just used the 'map controller' setting and it worked." Do you mean the Configure Input screen after you press start in emulationstation with a recognized controller? Or is there another way to map a controller that I've missed?

    Thanks for any help!!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.