Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Games (PSX only card) won't load after general update



  • Hi there,

    I just have another issue with other of my raspberry cards. First of all, info:

    Pi Model or other hardware: 3B
    Power Supply used: proper
    RetroPie Version Used: 4.4.11 (updated today)
    Built From: retropie-4.2-rpi2_rpi3.img (long time ago)
    USB Devices connected: none
    Controller used: PS3 sixaxis
    Error messages received: None
    Log found in /dev/shm/runcommand.log (if relevant):

    Parameters:
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-pcsx-rearmed/pcsx_rearmed_libretro.so --config /opt/retropie/configs/psx/retroarch.cfg "/home/pi/RetroPie/roms/psx/Crash Bandicoot.cue" --appendconfig /dev/shm/retroarch.cfg

    Guide used: No. I just update.
    File: ¿?
    Emulator: lr-pcsx-rearmed (I only have this one installed in this card)

    Ok. I just update the RetroPie version and the emulator. Then, games won't load. I start a game, I can see the splashscreen... and then it goes back to the games list screen.

    Then, after checking some threads, I read that a general update (everything: OS, RetroPie, emulationstation, retroarch,...) this kind of problems usually vanish.

    But not, I do a general update (by "UPDATE" function in main menu of RetroPie Config), but all is the same. Games won't load: I can see the splashscreen and then goes back to the games list.

    I don't know what to say more... Maybe the log of runcommand log:

    Parameters:
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-pcsx-rearmed/pcsx_rearmed_libretro.so --config /opt/retropie/configs/psx/retroarch.cfg "/home/pi/RetroPie/roms/psx/Crash Bandicoot.cue" --appendconfig /dev/shm/retroarch.cfg

    Any help? Thanks a lot!

    EDIT: I wanted to update my system because recently I discover that one of my issues posted here (https://github.com/libretro/pcsx_rearmed/pull/240) was solved. And I wanted to check if it run ok.

    EDIT 2: I MADE AN UPDATE OF LR-PCSX-REARMED FROM "SOURCE" AND THEN IT WORK! Very odd... Before shut the thread... Anyone know why I need to do a update by source?


  • Global Moderator

    @Loquo Maybe because there was another problem fixed recently and the binary wasn't updated until today. If you update from binary again, do you still get the problem ?



  • To be honest, I would prefer not to do it... Not until I do a backup (I need 200 GB free for do a backup of this microSD card).

    Thanks anyway!

    PD: I could check the issue of Lifeforce Tenka was indeed solved. Now, everybody can play Tenka :)


  • Global Moderator

    @Loquo You can only update the lr-pcsx_rearmed package, you don't have to run a full update.



  • I'm scared about do it. I think, if after update (by binary) lr-pcsx_rearmed the problem come back, maybe the source update this time doesn't fix it.

    RetroPie, for people like me that keep using Jessie, every update it's scary. x(

    I would prefer do a backup before, even if I only gonna update the lr-pcsx_rearmed.


  • Global Moderator

    @Loquo said in Games (PSX only card) won't load after general update:

    I'm scared about do it. I think, if after update (by binary) lr-pcsx_rearmed the problem come back, maybe the source update this time doesn't fix it.

    There was no source update in 3 days, so installing from source should get your the same - working - version you have now. I don't think there's anything to loose here, but if you don't want to experiment, that's fine.



  • @mitu I think the problem is that @Loquo is using Jessie, and since a while there haven't been any more updated binaries for it. This means that the last lr-pcsx-rearmed binary package for Jessie probably uses the old libretro.sofile name for the installed core and the current scriptmodule configures the system to launch the new pcsx_rearmed_libretro.so core name instead.

    This is not a problem when you build from Source, even in Jessie, because the scriptmodule always builds with the current/right library name.

    In summary, for Jessie the core only will work when building from Source as I think @BuZz stopped updating binaries for Jessie.

    @Loquo nothing is wrong with updating from Source, don't worry. However, you won't be able to obtain updated binaries anymore unless you migrate to Stretch. The same applies for other cores/components too, you won't get any more updates unless you update from Source.



  • Thankes @hhromic.

    Is there any option to migrate to Stretch without start from the begining?

    I keep using RasPi 3B (not 3B+).

    Thankes!



  • @Loquo unfortunately there is no easy/safe/foolproof way to migrate from Jessie to Stretch. There are usually fundamental design changes between OS versions (for example system file locations and configurations) that are impossible to track properly and migrate, hence it is recommended to just start from scratch and re-configure.

    I know it is a hassle, but eventually you will have to migrate if you plan to keep updating your system. Fortunately RetroPie also has been evolving since older versions and the installation/configuration of the components has turned easier and less prone to errors. It is not perfect, but def improving.

    Lastly, moving to Stretch is not only for RPI 3B+ users, other RPI models benefit as well from updated firmware (including video drivers), kernels and system tools. For example, PS3 controller compatibility is much better, no matter what Raspberry Pi model you are using.



  • Thanks @hhromic .

    I knew that it's not easy to migrate from Jessie to Stretch.

    Maybe, I should wait for the next evolution of Raspberry Pi... For me, do this migration is a vast amount of time moving files out and in the system.

    Thank you!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.