Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Amiberry loading LHA or ISO challenges



  • Hi all.

    Apologies for the request for help, but I cannot for the life of me move this forward, and I'd appreciate any help you can provide.

    Context:
    1 - I never owned an Amiga, so I don't know the specificities of using it.
    2 - I am trying to run the Time Gal and Road Blaster remakes/fan projects from here. They are provided in several formats - I tried the LHA files for AGA, and ISO files for AGA.
    3 - I read the tutorial by @nemo93, and the documentation by @HoraceAndSpider . I even consulted some of his GitHub repositories via Google searches.

    I'm on RetroPie 4.4, I believe, and just installed AmiBerry from binary. I added the .LHA file extension to my es_systems.cfg file so all is running well.

    Now, where do I stand:

    • In the tutorial, at one step it says that I should update WHDLoad settings from the internet. Alas I get a message saying that I do not have an internet connection (even though I do - I SSH into the Pi and run a ping to a remote server and all goes well. Oh, and Kodi also connects to external sources. Same for RetroAchievements in other cores). I imagine this might be a problem.
    • If I try to run the LHA files, I get the AmiBerry splash, then the WHDLoader screen, and then a message saying something to the effect of "0 slave files found" or similar. That's alright, as I didn't expect that the LHA file I had was a WHDLoad compatible one. Maybe this would be solved if the previous step ran, maybe not?
    • If I try to run the ISO, mounting it on a CD Drive, either running the AROS or CD32 ROMs, I get the "eyes" or the screen with the animation of a floppy entering the drive (I assume, prompting me to enter a disk as no bootable media has been found?).
    • If I mount a blank ADF disk into it, if it's bootable I get the Amiga prompt in a sub-window, otherwise it stays the same.

    So, this is probably absurdly obvious to anyone that owned an amiga or is more experienced with the emulator, but I am kind of at a loss here. Any pointers would be very much appreciated, as well as requests for information from me.

    Also, apologies for any miscommunication of concepts and whatnot - I'm not familiar with the Amiga terminology myself, being a Spectrum guy.

    Thank you in advance for your time, and happy Friday!



  • @pjft I would test Amiberry with a supported game first to make sure it has installed correctly and that it is picking up the correct KickStart file(s). In addition, this will let you familiarise yourself with the emulator, in particular the WHDLoad Autoboot process.

    SWOS 96-97 is a well tested game and would be a good choice. The LHA file you should be looking is SensibleWorldOfSoccer9697_v1.7_0842.lha.

    It is possible to see the contents of a LHA archive using 7-zip from the command line.

    If I run 7z l SensibleWorldOfSoccer9697_v1.7_0842.lha, then, in the list, I see the slave file, SensibleWorldOfSoccer9697/SensibleWorldOfSoccer9697.Slave.

    If I run 7z l TimeGal1.3c-AGA.lha, then there is no file with the .Slave extension which, I suspect, is why you see the message stating no slave files found. The FAQ mentions requesting an official installer for these cases so it may worth approaching Pixelglass Games.

    Once SWOS 96-97 is running, you could also raise an issue at the Amiberry github regarding getting Time Gal and Road Blaster working.

    I'm afraid I can't help with ISO and ADF files as I have only used LHAs.



  • Hi @dudleydes and thank you so much for taking the time. Those sound like a wise approach, I'll look into them and see if I have any luck with SWOS - certainly a game I enjoy quite a bit! If you're into that, there's an unofficial 2016-17 update that's also whdload compatible which you can easily find on Google.

    I also dropped a line to the folks that made the games in hopes that they create a proper Slave file.

    Hopefully in the weekend I'll have some more time to look into this. Thank you and have a great weekend!



  • So, a small update!

    I managed to load the ISO files from within the AmiBerry menus, and if I create a .uae file and add that extension to the accepted extensions in es_systems.cfg, that works for the old ISO files.

    Now, for WHDLoad, the creator of the games ended up sharing a link for a LZX file which someone had created (which I ended up having to decompress and then compress into LHA).

    ftp://ftp:any@grandis.nu/~Uploads/Aladin/WHDLOAD generic/RoadAvengerAGA-WHDL.lzx

    That being said, while WHDLoad runs, and detects the slave files (I used the Kickstart 3.1 one), it then results in a black screen with debug logs claiming that they "can't allocate expmem", which is probably something that would need to be supported via an update to whdload.xml . I'll submit something on the project's GitHub.

    So thank you for all the guidance and help as these have set me on the right path!

    The only thing I'm missing now is that I can load the OCS versions from CD, but the AGA ones I cannot because they are not compatible with the CD32 drive speed (2x), and I can't seem to boot any other Amiga model from CD straight away, but when running from CD32 it stutters a lot.

    Any idea if I can change the CD drive speed in Amiberry or, alternatively, if I can boot any other Amiga model from CD?

    Thank you so much @dudleydes for helping me start out on the Amiga front!


  • administrators

    You mention btw modifying your es_systems.cfg - I assume you are maintaining your own as these extensions should be in there by default?



  • @BuZz That's a good question. I had plenty of extensions there for Amiga already, as I had uae4All installed, but I did not have LHA there - maybe it's because I have a modified es_systems.cfg or something. I honestly can't tell. Nor .LHA nor .UAE, surprisingly, but adding them worked wonders.

    My original RetroPie version predates Amiberry, which is the first with LHA support I believe, according to the wiki, so it might be that?



  • The “Aladin” unofficial WHDLoad archives should be supported but are a real pain for me to maintain compatibility of becuase they are so inconsistent in content.

    I will have a look and see why this one doesn’t work straight off
    .



  • @HoraceAndSpider

    By all means, thank you very much for taking a look. The links are these (I think these are ok here, as they are fan remakes, but let me know otherwise):

    ftp://ftp:any@grandis.nu/~Uploads/Aladin/WHDLOAD generic/RoadAvengerAGA-WHDL.lzx
    ftp://ftp:any@grandis.nu/~Uploads/Aladin/WHDLOAD generic/TimeGalAGA-WHDL.lzx

    I had to convert them from LZX to LHA (unless I shouldn't have?), and it might also certainly be an issue on my end as, as I mentioned, I have little familiarity with the Amiga ecosystem.

    Apologies for the trouble, and thank you for your time and dropping by. By the way, thank you for your GitHub repository - it was tremendously helpful in getting this set up :)

    EDIT: if it helps, I'm happy to share the created config files for WHDLoad for these in my setup. Maybe it's just something absurdly obvious. Thank you and let me know how I can help.



  • This post is deleted!


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.