Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retroarch Cannot Install Packages



  • I've installed retropie on my computer running Ubuntu 19.04. During install it states that retroarch could not install several packages and as a result does not show as installed on the retropie setup. I believe this is causing my roms not to be able to load. Nothing works across all systems. I know the roms are good.

    Screenshot from 2019-05-06 07-01-47.png

    Log File:

    Log started at: Mon 06 May 2019 07:01:35 AM EDT

    RetroPie-Setup version: 4.4.12 (8e4f86d)
    System: Linux joshua-GT75-Titan-8RG 5.0.0-13-generic #14-Ubuntu SMP Mon Apr 15 14:59:14 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

    = = = = = = = = = = = = = = = = = = = = =
    Installing dependencies for 'retroarch' : RetroArch - frontend to the libretro emulator cores - required by all lr-* emulators
    = = = = = = = = = = = = = = = = = = = = =

    Did not find needed package(s): libxkbcommon-dev libusb-1.0-0-dev libvulkan-dev libavcodec-dev libavformat-dev libavdevice-dev nvidia-cg-toolkit. I am trying to install them now.
    Hit:1 http://us.archive.ubuntu.com/ubuntu disco InRelease
    Get:2 http://us.archive.ubuntu.com/ubuntu disco-updates InRelease [97.5 kB]
    Get:3 http://us.archive.ubuntu.com/ubuntu disco-backports InRelease [88.8 kB]
    Get:4 http://security.ubuntu.com/ubuntu disco-security InRelease [88.4 kB]
    Fetched 275 kB in 5s (50.1 kB/s)
    Reading package lists...
    Reading package lists...
    Building dependency tree...
    Reading state information...
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libsdl2-dev : Depends: libsdl2-2.0-0 (= 2.0.8+1) but 2.0.9+dfsg1-1ubuntu1 is to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    Could not install package(s): libxkbcommon-dev libusb-1.0-0-dev libvulkan-dev libavcodec-dev libavformat-dev libavdevice-dev nvidia-cg-toolkit.

    Log ended at: Mon 06 May 2019 07:01:42 AM EDT
    Total running time: 0 hours, 0 mins, 7 secs


  • Global Moderator

    Ubuntu 19.04 is not yet supported OOB. See this topic for a workaround.



  • I was able to fix the install with the instructions on that link. Thank you.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.