Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Megadrive is the only emulator with no sound, anything else works



  • Hi, I have been looking for an answer for quite a lot of time and I simply gave up. Please, any help would appreciated.

    Pi 3B
    Power Supply used: 5v
    RetroPie Version Used: just updated on May the 8th 2019
    Built From: Pre made SD Image on RetroPie website
    Emulator: Megadrive (Genesis)

    Megadrive (Genesis) is the only emulator to have this issue.
    I have tried to change audio drivers in retroarch, but whichever I chose none worked.
    Any game I run from the Emulator Megadrive has the same issue.

    I am using lr_picodrive as emulator. The other one working is lt_genesis_plus_gx.
    At one point I had the issue of the games in megadrive running incredibly fast. This issue was solved by selecting resolution and frame rates (at 27 Hz).
    But no sound issue was solved.

    I do not think HDMI or 3.5 jack are an issue as I get any other sound out.

    Whichever audio drivers I try, I get the same result: Megadrive games have no sound, any other station works perfectly fine.

    Do you have any idea/suggestion?
    Thanks!!!
    Giorgio



  • @gioo7 do you have any other roms? They use the same emulator. As do Sega CD and Sg1000. 32x uses one of them (lr-picodrive) and game gear uses the other (lr-genesis...)


  • Global Moderator

    Do you have any core/game overrides saved ? Can you check the sound volume ?
    You don't need to change the sound driver, if it works in RetroArch for other cores. Can you check if you didn't accidentally set the Mute setting in the Audio menu in RetroArch, or set the volume at zero ?

    8b417c14-83fd-4f8d-b3da-a3d21f804cd0-image.png



  • @simpleethat thank you for your suggestions, I really appreciate it!
    I have checked all the emulators I am using and none of them uses lr-picodrive. Do you think that I may "reinstall" it somehow?



  • @mitu
    Thank you so much, I already checked it and mute is on OFF
    @simpleethat
    however I do encounter 2 strange behaviors:

    1- Every time I go to the MAIN MENU and then SOUND SETTINGS, I see the System volume dropped down to 0. I don't think this actually is an issue as I hear other sounds.

    2- whichever game, menu or settings I open, while changing screen, during the black screen I see the following message:
    "ALSA lib control.c:1373:(snd_open_noupdate) Invalid CLT hdmi lvl0: VolumeControl::init() - Failed to attach to default card!"
    Again, I never bothered it as sound works everywhere else

    Could this be the issue?


  • Global Moderator

    @gioo7 said in Megadrive is the only emulator with no sound, anything else works:

    Could this be the issue?

    No, that's because Emulationstation can't find the mixer (?). Fiddle with the AudioDevice settings in the settings and it will be solved.

    As for the other issue, try resetting the configuration for the megadrive system - rename the /opt/retropie/configs/megadrive/retroarch.cfg and then re-install (update) the lr-picodrive emulator.



  • @mitu
    Thank you. I will rename the file just in case.
    but my question is how do I reinstall it?
    by updating retropie?
    sorry, I am not an expert as you are.
    btw, really thank you for taking the time to help me!


  • Global Moderator

    Use the RetroPie menu in Emulationstation and start the RetroPie-Setup - https://retropie.org.uk/docs/Updating-RetroPie/#using-the-retropie-setup-script - then update lr-picodrive, it's in the main packages section.



  • @mitu IT WORKED!!!
    Finally :)
    I had to reconfigure buttons but besides those details it completely fixed the problem!!
    thank you really


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.