Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

AdvMAME not detecting controller



  • I'm running a Raspberry Pi 3B+
    Controller: PS3
    USB devices: Flash drive, keyboard, PS3 controller
    Built using download from RetroPie site
    Retropie version: 4.4.12
    RetroArch 1.7.6

    I've been trying to get a set of arcade games to work using AdvMAME emulator. I dropped the roms into a separate AdvMAME system folder as well as the Arcade folder. The games boot but it does not detect the controller. Tab key works on the keyboard, but I see no way to set up controller detection. The "Calibrate joystick" option does not respond.

    I read somewhere that that AdvMAME.rc file could be edited to enable Device_joystick to go from "auto" to "raw", but that didn't work. I also see Device_keyboard is set to raw, but that probably doesn't matter. I edit all three files: advmame.rc, advmame-0.94.rc, and advmame-1.4.rc and nothing helped. This also did not enable the "calibrate joystick" to work either.

    How do I get it to detect the joystick so I can begin remapping?


  • Global Moderator

    What joystick/gamepad you have and how is it connected (USB/Bluetooth/GPIO) ?



  • PS3 noted above, connected by USB



  • @leitmotiv Does the controller work in Emulation Station? If yes then the system recognizes it. You can run jstest from cli to check all the buttons etc.

    https://retropie.org.uk/forum/topic/543/joystiqs-buttons-and-jstest

    Which advmame version are you running? I use 3.9 which is advmame.rc file, you have to map the controls separately. You should be able to hit tab and map the controls from the main menu. There should be two options, Input (General) and Input (This game). I am using xbox 360 via usb and my setting is device_joystick auto



  • EmulationStation is just the menu in which I scroll through the different systems and games yeah? Yeah my controller works for everything there and any game I play with, except AdvMAME. I have three versions of AdvMAME installed. AdvMAME itself is 3.9.

    I can hit tab when I boot a game up. I see the area to map controls but it does not detect my button inputs.



  • yeah ok just making sure the controller is working outside of advmame was all. Have you tried loading the driver for the PS3 controller? I think that is only needed if you are using bluetooth though.



  • just FYI saw another post on PS3 and the guy put device_joystick sdl to make it work



  • Just tried editing to device_joystick sdl in the .rc file and that didn't work either. I'm editing all three advmame .rc files for the three different versions .94, 1.4 and 3.9.

    I know how to remap using the mame by pressing tab key, but it shows the controls are already there, but it just doesn't detect my controller.

    I'm not sure what a jstest is. That link wasn't entirely clear. But if it's referring to the controller detection and initial setup, I did that a long time ago. I have many game systems that all use the PS3 controller including Arcade games using FBA, MAME 2000 thru 2015. AdvMAME is the only thing not detecting the controller.

    The PS3 controller driver was never loaded. But we don't use bluetooth.


  • Global Moderator

    @leitmotiv Advmame has a joystick/gamepad test utility - advj - can you try running it from the command line to see if it detects the gamepad ? Run it with /opt/retropie/emulators/advmame/bin/advj.



  • running it right now... says Joy 0 and Joy 1 is PS3 controller, but it's still working...



  • How long is this supposed to take? Seems like it's stalling out for a simple test.


  • Global Moderator

    @leitmotiv I think it doesn't exit by itself, you have to interrupt it - press CTRL+C.



  • I used PS3 Controllers for AdvanceMame for three years and had no problems

    But i miss a step here.
    Before you can map the buttons in "input/general" you have to config the buttons for the TAB-MENUE itself.
    You do that in "input/general/Interface" by using a keyboard and set the actions to pad-buttons.
    There you have to set the buttons for all directions and at least for Button "A" to use the Joystick within the TAB-Menue.

    I recommend to set analog + digital Inputs for directions, AdvanceMame supports multi-buttons for one action.
    So you can decide per game how you want to control it



  • All right so...

    I went into input/general/interface. I tried editing controls for UI interface as well as P1 and P2 controls. None of it worked. It would detect the controller in that menu only. But not with the game. Also, it would not detect the right D-pad button in UI or either of the P1 or P2 controls.

    Also, this is with it still set to device_joystick sdl



  • I assume you have two PS3 controllers connected via USB then? Have you tried just 1 connected if so?



  • Nope, just the one. Though I really should have another.



  • lol I hear ya. I'm not much help here I guess, I have a few different controllers and they all have worked fine with advmame 1.4 and 3.8/9. Did you also try using 1.4 when launching a rom instead of 3.9?



  • I didn't. The specific game I was booting up doesn't work with any other core except AdvMAME .94



  • ah ok.. I've never used .94 only 1.4 and 3.9 which both worked great. Which game are you trying?



  • The .94 game was Exvania. I will try the other cores here in a bit.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.