Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Connecting to Retropie?



  • Hi everyone, ive got a problem connecting to my retro pie! It was working perfectly, then i changed my computer to connect to router via dmz, to have open nat type on call of duty black ops 3 custom zombies! I also updated my retropie to the newest version (was already 4.4 but updated it for themes)

    Firstly it asked for user and password when starting, this i fixed easily in the settings (after googling). Then i tried to connect to it for the first time since making these changes, it would not connect (\RETROPIE). I automatically assumed that because i changed my computers connection to the router it was that so i simply changed it back. This did not work!!

    I tried for several hours and eventually got it to connect, copied 7 snes games, no problem, tried to copy 1 psx straight after, it had disconnected at 10%! I tried logging in with Winscp and filezilla, without any luck! Ive turned SSH? on, and if i click it again it still says to click to enable so unsure if its enabled?! I have tried two computers, no luck!

    The router is a BT Home Hub 6 (if that helps) it puts out a normaly connection and a 5Ghz one, have tried connecting both pi and laptop to both (same at a time) doesnt work!

    Sometimes the pie will show up in my network (on left panel when in this pc) other times it will not, unsure how to proceed! It is a fairly new build, couple of weeks at most, only updated to get access to more themes! Also only have snes, 3 n64 and kodi on it so not played with it to much!

    Any help would be great, Thank you!


  • Global Moderator

    @rmills55 said in Connecting to Retropie?:

    It was working perfectly, then i changed my computer to connect to router via dmz

    I think this is your problem - looks to be network related, maybe the DMZ doesn't have access to the LAN (where your PI is located). If you switch back the network router configuration for your PC, do you still have the same problem ?



  • @mitu said in Connecting to Retropie?:

    @rmills55 said in Connecting to Retropie?:

    It was working perfectly, then i changed my computer to connect to router via dmz

    I think this is your problem - looks to be network related, maybe the DMZ doesn't have access to the LAN (where your PI is located). If you switch back the network router configuration for your PC, do you still have the same problem ?

    Hi, thank you for your response, yes it still happens once i changed back. On my router i can only set one system on DMZ, so the other pc which also didnt work was not set as that to dmz ever! Ive just checked now and its worked again, copied snes games worked, then tried to copy pc engine game this time and its kicked off again

    EDIT:
    If it helps, ive got a shortcut on desktop to my retro pie ip, i dont use \RETROPIE, neither work but they do spend about 3 mins trying to connect before it tells me there is a connection problem, so i guess its seeing it. Tried pinging it from cmd (the ip) and this didnt work either



  • @rmills55 Are you sure that your computer received an internal IP address from the router after you switched it off DMZ? I've found that when i do need to use DMZ i have to reboot the router before it actually forwards the public IP to the device and im assuming the same goes for the reverse.

    If your router actually does a true DMZ you should NOT have access to other devices on the network when its enabled by design. Though a half baked DMZ which ive also seen ~kind of~ does, pretty much exactly what you're describing.

    I personally think that exposing a windows computer to the internet is a really bad idea and would have opted to forward specific ports instead, but maybe COD doesn't work well with that or uses some random ports each session...I don't know.



  • In terms of network security, it is prefered to open/forward ports in the routers configuration that are required by the games/applications that use them in order for online multiplayer to work.

    I would probably had looked up on what port number that Call of Duty Black Ops 3 uses and then forward that port on the router instead of using dmz. Using dmz could make your computer unsecure and exposed as what @Parabolaralus mentions and it still might not work.

    Try disabling dmz and have a look on what IP address your computer and Raspberry Pi receive. They need to be on the same network. for example: 192.168.0.2 and 192.168.0.254.

    Usually the first given IP address on a network is your router. typically 192.168.0.1 and that will automatically give you a dynamic IP address to your computer and other devices such as your Raspberry PI.

    You could also open a command prompt on your computer, then type ipconfig and see what IP address your computer has received. The same is also said for Raspberry pi. Instead open your linux terminal or in Command line, type ifconfig.

    When you know what IP address your computer and Raspberry Pi has, try using the ping "ip address of Raspberry Pi" to see if Raspberry Pi responds back to your computer.



  • @tpo1990 said in Connecting to Retropie?:

    The same is also said for Raspberry pi. Instead open your linux terminal or in Command line, type ifconfig.

    In Debian Stretch / Retropie 4.4, ifconfig was replaced by ip addr.



  • @Clyde Well ifconfig works just fine in Debian Stretch / Retropie 4.4

    I just tested it in the linux terminal. It also seems that ip addr works as well.

    So doesnt matter which one will be used. Either one will do just fine. :-)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.