Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

"k" up in the corner with Atari Basic



  • When running Atari Basic on the Atari 800 emulator there is a "k" up in the upper left hand corner. Is there a way to get rid of that?



  • @bkumanchik The k is because you have loaded a "k-file," which is a specially optimized variant disk format for faster loading. It's generally noted in the game filename, like

    Zombies (1983)(Bram)(US)[k-file].atr

    It's a bit odd that you are in BASIC and see it, usually it goes away once you are in the game and it tends to be on games that are machine language. For those sorts of games, you want to disable BASIC.

    If your goal is to do some BASIC programming, I suggest finding a DOS 2.5 system disk, and booting to that with BASIC enabled.

    If your goal is to load a game and you are getting dumped to BASIC, I suggest disabling BASIC in the RGUI menu (Select-X, Options, set BASIC to disabled).

    I just posted a giant thread explaining most everything about Atari 8-bit emulation in Retropie here: https://retropie.org.uk/forum/topic/22392/lr-atari800-5200-artifacting-basic-and-other-guidance



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.