Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Snes screen kinda tearing



  • build 4.4.12
    pi3b

    Li-snes9x2010

    so i finally got to play my PI or i should say my wife did and she played Super Mario World for about 2 hours. Everything seemed to work fine

    but she did say that the screen seemed kinda off. i think she meant screen tearing when mario was moving fast. and it was only a few times

    Now i just rebuilt my system last week and have not messed around with the video seeings. so they are all stock
    is there something i should have them set for

    we have a 65inch QLED if it matters.



  • @ExarKunIv i think a 65 inch screen is going to make any minuscule tearing look bad. Is your tv in game mode?



  • Actually, if you update to the newest retroarch; retroarch core update. There is a new option that might be worth testing. It is found in retroarch >> settings > Frame Throttle > Sync to exact framerate (g-sync, freesync).

    Be weary if you do a full system update and update the kernel modules, there was a kernel module update for bluetooth that hindered its ability to connect to controllers or something. This if not has been fixed hence.


  • Global Moderator

    What's the resolution and refresh rate on the TV ? If you're running at 30hz, you'll experience some screen tearing. RetroArch has a 'video_vsync' option to smooth the display, but it's turn on my default - you can check from the RGUI in the Video settings, where you can also check the refresh rate

    c84e190d-3f35-4032-9eeb-336bf4413cdd-image.png



  • @edmaul69 no it is not. i all my video going through my receiver and switching it back and forth is a pain so i always just leave it

    @Efriim i will take a look at that, as for the bluetooth. my 8bitdo connects and works just fine with 4.4.14

    @mitu i will have to take a look i dont know off the top my head if is at 30 or 60 i do belive the rez is 1080p. like i said to Efriim i will take a look into the v-sync

    i will keep you guys updated when i get time to mess with it again



  • @ExarKunIv
    The Videogame mode on most flatscreen tvs, as well connecting the hdmi from the pi directly to your tv, will improve the experience significantly when the tv and receiver aren't taking extra time to process the image for whatever they call clarity.
    It could probably be the receiver causing tearing, but hdmi game-mode setting on the tv will lower the milliseconds it takes to get the frame displayed on screen.



  • Something to try is setting the aspect ratio within the emulator to PAR or 8:7 rather than 4:3. I've noticed this removes alot of shimmering on my setup, it might alleviate the screen tearing you are observing.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.