Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Font crash with custom theme



  • I'm developing a theme for personal use to go with my Retroflag GPi case. In the theme I take assets from two other themes and modify them to have a green gameboy palette. Everything is working fine except the Truetype fonts I'm using . The theme instantly crashes when it comes across a view with the fonts I'm using. They work fine on the PC version of EmulationStation but crash with an error message on the Pi Zero W.

    I attached some screenshots. The font at the bottom and on the game list is what I'm trying to use.

    Error message: emulationstation: /home/pi/RetroPie-Setup/tmp/build/emulationstation/es-core/src/resources/Font.cpp:17: Font:FontFace: :FontFace(ResourceData&&, int) : Assertion '!err' failed.
    Aborted

    Screenshots
    nes.png genesis.png gamegear.png gameboy.png


  • Global Moderator

    @lion2 This usually means you haven't copied the font files or if the font path declared in the theme file is not correct. Remember that Linux filesystems are case sensitive, a font path that might work on Windows would not be valid on Linux.
    Upload your theme and we'll see why the crash happens.



  • I'll double check the paths, but I'm not near my Pi Zero to test anything. My theme is in the link below.

    https://www.dropbox.com/s/a9pvh6l5sq3uv5i/PortablePowerFont.zip?dl=0


  • Global Moderator

    @lion2 I think the path is the problem - the font is declared in the system's theme.xml as

    <fontPath>./../_inc/fonts/ARCADECLASSIC.ttf</fontPath>
    

    but the filename is all uppercases (ARCADECLASSIC.TTF). Try changing the font filename and see if you still get the crash.



  • @mitu Makes sense! I guess I just overlooked that after all the recoloring work I did last night. I'll try that as soon as I get home and update. Thank you!



  • @mitu Fixing the case sensitivity worked! Thanks for your help.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.