Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

ScummVM games not launching from menu



  • Hi!

    I set up Scumm VM as instructed in the wiki.
    My problem is that I cannot launch ScummVM games from the game list menu.
    It works fine is I launch +Start ScummVM.sh and launch the games from there.
    I also tried launching via commandline $./'+Start ScummVM.sh' comi, and that works fine.
    When I launch in the retro pie menu it gives me an error: "unexpected (".
    My guess is that it tries to execute comi.svm as a script. Because it contains:

    The Curse of Monkey Island (Windows/English)
    

    and the first parenthesis would cause the error.
    I probably could create a script <game>.sh for every game that runs the start scummvm script with the game as a parameter, but I don't want to do that manually for all my games.
    Any idea why this is happening or what I should do to fix this?

    Thanks
    /L


  • Global Moderator

    @langest Add more info about your system - https://retropie.org.uk/forum/topic/3/read-this-first. What version of RetroPie are you running ?



  • Pi Model or other hardware: 3B+
    Power Supply used: Official power supply
    RetroPie Version Used: 4.4.14
    Built From: Retropie image
    USB Devices connected: 4 controllers and a memory
    Emulator: ScummVm

    $ /opt/retropie/emulators/scummvm/bin/scummvm --version
    ScummVM 2.0.1pre (Mar 17 2019 17:46:21)
    Features compiled in: TAINTED Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib MPEG2 FluidSynth Theora AAC FreeType2 JPEG PNG keymapper virtual keyboard
    


  • Is the game Blade Runner works? It seems in PC version yes. Tried and with last commit dont detect the game.



  • @Gwyllion I'm not sure what you mean or how this relates to my problem.
    What do you mean?


  • Global Moderator

    @langest There must be a bug some int he runcommand launching .svm files containing ( (a shell reserved character). Can you post the /dev/shm/runcommand.log file after you unsuccessfully launch a .svm file ?



  • This post is deleted!


  • @mitu
    It seems like the log only contain the latest game I ran before I unsuccessfully ran the ScummVm game.
    It suggests that my guess is correct and that it tries to run the svm as a script but fails since it is not a script. It's just the name of the game (The Curse of Monkey Island (Windows/English)). And the first ( in the name is what is causing the error. I set up the svm files through the ScummVm menu using "Add Game".



  • Is there anyone else who has ScummVm set up? What do you have in your <game>.svm?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.