Please do not post a support request without first reading and following the advice in

Can't change resolution, /opr/retropie/configs/all is owned by root

  • Re: Default Resolution Error - All Emulators Affected

    Just configured Retropie, I'm getting same issue, can't change resolution. I've found out /opt/retropie/configs/all is owned by root:root . I then chown -R to pi:pi and I get everything working, I can change resolution and so on cause everything is writable br pi user. But when I reboot the raspberry I get /opt/retropie/configs/all is owned by root:root again.
    WTF ?

  • IIRC, doing this this will reset configs folder too

    To reset all your rom file ownerships back to the "pi" user, enter the RetroPie-Setup Script navigate to Configuration / Tools >> resetromdirs

    You can check if it is fixed by doing

    cd /opt/retropie/configs
    ls -la


    cd /opt/retropie/configs/all
    ls -la

    and you will be able to check if folders are still owned by root instead of pi.

  • This does correct permissions and now /opt/retropie/configs is under pi:pi , thanks.
    But I still have the problem on restart/boot I get it again under root user.

    drwxr-xr-x 40 root root 4096 May 18 23:12 configs

  • Going in depth I've found out autoconf.cfg is the only file which has root owner.

    -rw-r--r-- 1 root root 248 May 23 21:04 autoconf.cfg
    -rw-r--r-- 1 pi pi 23 Apr 14 2018
    -rw-r--r-- 1 pi pi 26 Jun 7 22:06 bluetooth.cfg
    -rw-r--r-- 1 pi pi 4096 Feb 4 14:28 ._.DS_Store
    -rw-r--r-- 1 pi pi 8196 Feb 4 15:18 .DS_Store
    drwxr-xr-x 7 pi pi 4096 Jun 18 16:44 emulationstation
    -rw-r--r-- 1 pi pi 4096 Jun 1 06:33 ._emulators.cfg
    -rw-r--r-- 1 pi pi 92385 Jun 14 21:44 emulators.cfg
    drwxr-xr-x 16 pi pi 4096 Nov 29 2018 retroarch
    -rw-r--r-- 1 pi pi 4096 Apr 28 14:49 ._retroarch.cfg
    -rw------- 1 pi pi 28926 Mar 2 14:36 retroarch.cfg
    -rw------- 1 pi pi 28926 Mar 2 14:36 retroarch.cfg.bak
    -rw------- 1 pi pi 30140 Jun 14 22:49 retroarch.cfg.rp-dist
    -rw-r--r-- 1 pi pi 57334 Jun 17 20:42 retroarch-core-options.cfg
    lrwxrwxrwx 1 pi pi 46 Jun 14 22:49 retroarch-joypads -> /opt/retropie/configs/all/retroarch/autoconfig
    -rw-r--r-- 1 pi pi 88 Dec 19 22:22 runcommand.cfg
    -rw-r--r-- 1 pi pi 2871 Apr 14 2018 runcommand-launch-dialog.cfg
    -rw-r--r-- 1 pi pi 205 Jun 10 16:17 scraper.cfg
    -rw-r--r-- 1 pi pi 1218 Jun 14 22:59 videomodes.cfg

  • Global Moderator

    This doesn't happen on a normal Retropie installation, you have another service/script running that messes up the permissions. Are you using a 3rd party image, by any chance ?

  • @mitu
    Nope , it’s an original iso, I had a 64gb but I got this behaviour, then I’ve installed a 128 one and then copied the /home/pi/RetroPie/roms and configs one from the 64 and now I’m getting this again. I have nespicase script running for power off . Btw maybe it’s better to start again from a clean installation or to restore the old config. I didn’t expect some config file to change permissions. I’ve also ran an update of all packages from raspi-config so can’t identify the exact time since I got this.

  • Ok, I've found the issue. Having set bluetooth connect mode to "background" makes autoconf.cfg to be owned by root . Setting bluetooth to "default" it correctly set autoconf.cfg to be owned by pi . This way makes possible to edit video configuration modes.
    My problem is, using a 8bitdo bluetooth gamepad, since the few last updates I'm having trouble to make it connect with bluetooth "default" mode and using "background" mode I was able to make it connect always. So I have to solve this problem bluetooth side. Any suggestions ?

    @mitu This sounds like a "ownership" bug, where these bug are reported?


  • administrators

    @mindfieldx I'll look into it

  • Hi,
    @BuZz Looking at the change log of 4.5 looks like this bug has been resolved?

  • Global Moderator

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.