Please do not post a support request without first reading and following the advice in

Steam controller driver "stop" command doesn't release controller

  • I am using a RP3B and a premade image of retropie that I have updated to version 4.4.15.

    I have a Steam Controller and I have installed the steamcontroller driver and have managed to get it working in desktop mode (keyboard / mouse) by running the command " start" during boot. This allows you to use it to navigate the ES menu as well. This also works great for mouse driven PC games in DOSBOX.

    Problems arise when you try to use steamlink as this prevents it from detecting the controller. Given that also has a "stop" command I thought what I could do is set up runcommand-onstart and onend scripts to "stop" the driver when starting the steamlink emulator. This didn't seem to work. I also tried to stop it from the command line and then ran steamlink again. Again, steamlink wasn't able to detect the controller.

    The only thing that worked was to remove the "start" from my boot sequence and then go straight into steamlink. Then the controller was detected. Running "start" and then "stop" on it should really have the same result but it doesn't, so it almost seems like some piece of clean up is not happening with the "stop".

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.