Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Problems with PSX Controller Configuration



  • Hey, first of all, I'm sorry for my weak English.

    I will report my problem quickly.

    This is the first time I install the retropie and try to configure it. I got perfect working with the SNES and NEO-GEO emulators.

    But with the PSX emulator only a few buttons of my control work, such as directional, analog and the X button (psx button), all other buttons do not work, this in all games I tested (Crash 2, for example). I performed the configuration of the control for the first time and in several frustrated attempts I tried to configure using Hotkey + Y> controls or settings> input

    Why does not the start, square, triangle, circle button work and only the directives and X work?

    I am using a generic usb control of Playstation 2.

    thx.


  • Global Moderator

    @bieelff Which emulator are you using for PS1 games - pcsx_rearmed or lr-pcsx_rearmed ? Can you try re-configuring the controller, during the configuration skip the Hotkey assignment and then accept the 'Use Select as Hotkey' settings ?



  • @bieelff also set the face buttons up like a snes controller and not an xbox controller. Then you dont have to remap them in the emulators.



  • After spending the weekend thinking about which procedure was done wrong, I remembered that I performed many installations and updates hoping to fix the problem, so I downloaded a clean .img and installed it again. After reinstalling the OS the control worked correctly, thank you anyway.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.