Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PSX game freezes in pause menu



  • Well, I got this error playing Tomb Raider 2 (is random, isn't a step guide to reproduce it), sometimes when I press Select button to save the game, it freezes, but, is random, sometimes it don't freezes, I even press that button over 9 times, and nothing happen, is random freezes like PSX issue (I'm using rearmed and schp1001 bios), there isn't any log.

    What could I do?

    Pi Model or other hardware: Raspberry PI 3 B+
    Power Supply used: microUSB 5V/2,5A f/Raspberry (output 5Vcc )
    RetroPie Version Used: https://retropie.org.uk/download/ v4.4
    Built From: RetroPie website
    USB Devices connected: 1 sentey keyboard
    Controller used: PS4 v2 wireless controller
    Error messages received: none
    Log found in /dev/shm/runcommand.log (if relevant): Didn't find anything, only this
    "
    selected sound output driver: libretro
    CD-ROM Label: TOMB_RAIDER_2
    CD-ROM ID: SLUS00437
    CD-ROM EXE Name: SLUS_004.37;1
    ari64_reset
    "
    Guide used: (Mention if you followed a guide) RetroPi guide
    File: there isn't file

    With verbose activated I only got this...

    [ERROR] [udev] Failed to open device: /dev/input/event2 (Success).
    [INFO] [udev]: Plugged pad: Wireless Controller (0:0) on port #0.
    [INFO] [udev]: Pad #0 (/dev/input/event4) supports force feedback.
    [INFO] [udev]: Pad #0 (/dev/input/event4) supports 16 force feedback effects.
    [INFO] [Autoconf]: 1 profiles found.
    [INFO] [autoconf]: selected configuration: /home/pi/.config/retroarch/autoconfig/Wireless Controller.cfg
    [INFO] [Joypad]: Found joypad driver: "udev".
    [WARN] [udev]: Full-screen pointer won't be available.
    [INFO] [Video]: Found display server: null
    [INFO] ALSA: Using signed 16-bit format.
    [INFO] ALSA: Period size: 384 frames
    [INFO] ALSA: Buffer size: 1536 frames
    [INFO] [LED]: LED driver = 'null' 0x1e41ac
    [INFO] Loading history file: [/opt/retropie/configs/psx/content_history.lpl].
    [INFO] Loading history file: [/opt/retropie/configs/psx/content_favorites.lpl].
    [INFO] Loading history file: [/opt/retropie/configs/psx/content_music_history.lpl].
    [INFO] Loading history file: [/opt/retropie/configs/psx/content_video_history.lpl].
    [INFO] Loading history file: [/opt/retropie/configs/psx/content_image_history.lpl].
    [INFO] [Config]: Saved new config to "/opt/retropie/configs/psx/retroarch.cfg".
    [INFO] Saving RAM type #0 to "/home/pi/RetroPie/roms/psx/Tomb Raider II - Starring Lara Croft (USA) (v1.2)/Tomb Raide$
    [INFO] Saved successfully to "/home/pi/RetroPie/roms/psx/Tomb Raider II - Starring Lara Croft (USA) (v1.2)/Tomb Raide$
    [INFO] Saved core options file to "/opt/retropie/configs/all/retroarch-core-options.cfg"
    [INFO] Threaded video stats: Frames pushed: 8410, Frames dropped: 8711.
    ari64_reset
    


  • bump, any help please?

    I want to play Tomb Raider 2, without it being freezes randomly pressing pause menu.



  • @niccco
    It is hard to tell what the problem could be, but I'll suggest some things you could try.

    Update the lr-pcsx core in RetroPie setup if you already haven't done so.

    I think this game has some form of CD copy protection of which I know very little about, it might be prudent to find a different image or you could try converting it to a single bin/cue pair.
    https://www.videohelp.com/software/CDMage
    Use CDMage 1.02b drag and drop the .cue file or open as MODE2/2352 then "save as..." this should save the image as single .bin/.cue pair.

    optionally
    https://www.psx-place.com/resources/psx2psp.586/
    This will convert a .bin into a compressed format that can also be used with pcsx.

    Do you have a different controller to test?



  • Has anyone experienced this problem and found an answer? I see the problem mentioned on many forums but no definitive answer, only suggestions.

    I began TR2 from the start and this exact problem began happening for me at the start of the Opera House (which may be a coincidence, something else may have changed at that exact time).

    I've made sure my lr-pcsx (on a 3B) is up to date and tried three different ROMs (one is a single bin/cue pair, others are multiple files). I've tried unplugging keyboard and mouse, I've tried various display and rendering resolutions as per some people's suggestions, but the very frustrating problem remains.



  • @shieladixon
    The things I would try in this order.

    Increase the emulated PSX CPU clock from 57 to 70.
    Use BIOS SCPH-550x, 900x, or romw.bin from PSClassic.
    Use the NTSC version of TR2.
    Convert the bin files into a single file using CDMAGE.

    Tombraider 2 is the one where you start at your mansion right? I haven't played much of the game. I explored all the mansion/training/hedgemaze for a couple hours and it didn't freeze on me, I don't know if I saved my game.



  • @Efriim I appreciate the suggestions. I wasn't aware of being able to increase the clock. I've done as you suggested but that didn't stop the problem. I am currently already using a single bin file and USA (presumably NSTC) version. I'll check my BIOS.

    In case anyone is reading this and is frustrated by the same problem, I've now at least found a way to 'unfreeze'.

    I discovered today that hotkey+right shoulder saves state. This is a little different from using the select button and passport. Seems to be an emulator feature rather than Playstation feature. It's instant and it saves to 'slot 0' (for me the passport saves to slot 1 and only offers me slot one, despite attempting to set up multiple slots).

    similarly, hotkey+left shoulder does a load state, which again is instant and loads from slot 0.

    These two key presses are really nice. They enable very quick saving and loading if you have a tricky jump etc. But take care, there's no confirmation on these.

    I discovered by accident that when the game freezes, you can use these key combos to save state and load state. You'd think that you'd be saving the frozen state but you're not. A save state followed by load state pretty much immediately clears the freeze, and does so without overwriting the game that you've saved via the passport.

    I'm really pleased to have found that, and I hope it helps someone else.


  • Global Moderator

    @shieladixon said in PSX game freezes in pause menu:

    These two key presses are really nice. They enable very quick saving and loading if you have a tricky jump etc. But take care, there's no confirmation on these.

    @shieladixon said in PSX game freezes in pause menu:

    These two key presses are really nice. They enable very quick saving and loading if you have a tricky jump etc. But take care, there's no confirmation on these.

    They are pretty 'standard' hotkeys for RetroArch - https://retropie.org.uk/docs/RetroArch-Configuration/#default-joypad-hotkeys



  • @shieladixon
    On speculation of the passport drive being a reason for the game to fail. I disclaim the unsusceptibility of usb drives to occasionally and inconsistently operate and provide data on Raspbian operating systems. However I provide no answer for this, it is only something I noticed at one point or another.



  • @mitu I'm still new to RetroPie / RetroArch. I was really pleased to discover those keypresses, but the important point is that those two keypresses allow you to continue when the game has frozen. Previously I'd had no option but to exit lr-pcsx and restart from my last saved point. And next time I'd try to save, it might have frozen again. it was taking a lot of time to make any progress.



  • @Efriim I don't know whether the problem is related to the passport / saving. The freeze happens when you press the option button for the inventory. So it could happen when you go to the inventory to switch weapon or light a flare or whatever.

    The freeze happens after you press the option button but before the inventory appears. Lara is just left frozen on the screen. If you use the 'save state' and 'load state' workaround I've described, then when the state is loaded again, the inventory appears, as if you 'saved state' the moment after hitting the option button but before the inventory started to appear.



  • @shieladixon Try setting the emulator to use the built-in HLE bios. There was an issue with Master Blaster Blasting Again, in which it would freeze when loading a screen, and I think you could save and load state around it, but also the HLE bios would work for some reason. Arc the Lad Arena/Monster Tournament, also freezes unless you use the built-in HLE bios.



  • @Efriim Thanks, I will try



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.