Please do not post a support request without first reading and following the advice in

lv10: Error parsing XML file

  • Hi,

    I've tried to solve this problem reading documentation on Internet but I don't know why there is this problem in my Retropie system.

    I did a fresh install of the latest Retropie OS in my Raspberry 3B+ two days ago.
    I updated all the system and packages (just in case) from the Retropie Config menu.
    I put some SNES games in roms folder under roms/snes/
    The games are showing and working in Retropie.
    I've tried to Scrape games list to get the covers but I got this error:

    lv10: TheGamesDBRequest - Error parsinig XML.
    Start-end tags mismatch

    I tried to see if there is no XML file into roms/snes/gamelist.xml and there is no file.
    I've created the file and I uploaded via FTP.
    I've changed the folders and files permissions and nothing.
    I get the same error.

    Maybe is something wrong with the updated packages?
    Another fresh Install would be great?

    I don't know what to do.

    Thank you!

  • Global Moderator

    @lupastance The error is because the of the scraper, it has nothing to do with your .xml files on disc. Did you restart Emulationstation (or your system) after the upgrade ? The version of Emulationstation from the 4.4 initial image doesn't work anymore with TheGamesDB scraping site, because of their API change, but an updated Emulationstation version should work.
    What's your RetroPie and Emulationstation version ?

  • @mitu you were right!

    I read about the API changed of EmlationStation but I had some packages conflict that I fixed with 'apt --fix-broken install' and after this I updated the EmulationStation as you said.

    All perfect now, thank you very much for the super quick answer.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.