Please do not post a support request without first reading and following the advice in

Emulationstation not sticking to 4:3 ratio

  • Hey guys and girls . Ive searched and asked reddit and facbook with no help .
    I'm having a weird issue with Emulationstation where it will not for the life of me go into a 4:3 screen ratio . It's forever staying full screen .

    I have so far changed to new themes set for 4:3 and nothing .
    overscan has zero effect.
    Change almost everysetting in boot/config file. and no change .
    The only trhing that has made a slight diffrence was

    emulationstation --resolution 640 480

    But wasnt in the centre of the screen and wouldn't save .

    Heres my boot config im using but like I said I have changed everything

    # uncomment if you get no picture on HDMI for a default "safe" mode
    # uncomment this if your display has a black border of unused pixels visible
    # and your display can output without overscan
    # uncomment the following to adjust overscan. Use positive numbers if console
    # goes off screen, and negative if there is too much border
    # uncomment to force a console size. By default it will be display's size minus
    # overscan.
    # uncomment if hdmi display is not detected and composite is being output
    # uncomment to force a specific HDMI mode (this will force VGA)
    # uncomment to force a HDMI mode rather than DVI. This can make audio work in
    # DMT (computer monitor) modes
    # uncomment to increase signal to HDMI, if you have interference, blanking, or
    # no display
    # uncomment for composite PAL
    #uncomment to overclock the arm. 700 MHz is the default.
    # Uncomment some or all of these to enable the optional hardware interfaces
    # Uncomment this to enable the lirc-rpi module
    # Additional overlays and parameters are documented /boot/overlays/README
    # Enable audio (loads snd_bcm2835)
    hdmi_cvt 480 800  60 0 0 0 0

    Any help or suggestion would be great

  • Also add that the bootscreen and all the games are set in 4:3 , which makes me think theres some hard setting in emulationstation overriding boot config.

    And I'm using a 4 inch Waveshare HDMI screen.

  • Global Moderator

    Try adding overscan_scale=1 to your config.txt file and then run emulationstation without any parameters.

  • @mitu no luck :( .

    It's a weird one because my boot screen and games are set correctly , it's just emulation station. So I did manage to get the screen to the correct aspect but it's not centred. I have no idea how I would centre the emustation image. I changed the code to auto boot like this

    Emulationstation --resolution 640 480 windowed 

  • Global Moderator

    @shawnclifton Emulationstation has also the ability to set a window display offset with the --screenoffset parameter

    --screenoffset x y

    Maybe this can help you position the ES window.

  • @mitu ahhh ok , I'm at work right now but I'll give it a try when im home . That looks promising tho .

  • @mitu That worked !!! 3 days that took and sleepless nights lol . Here's some code for people who may have the same problem


    emulationstation --resolution W H --windowed --screenoffset X Y

    Thanks a lot !

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.