Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Need help badly regarding PS4 controller



  • Hi,

    This is my first post. I hope im not breaking any rules or something.

    I got my (3 B+ raspberry pi) retropie set up, did my control config. and no matter how many videos or reddit posts I've read nothing has helped. It simply won't pick up the start/select buttons so that I can save my games. It picks the start/select buttons up just fine in the retropie menu but never in a game. I tried using F12 to save state but that doesn't work either and there is also no load state option in the in-game menu (this game) options. The controller is connected via USB cable. I re-imaged and re-installed everything, updated/upgraded everything. Still nothing.

    I was using mame4all games (turtles in time) to test this out. I also tried the simpsons arcade game rom. These are the only two roms I have that I got to work so far.

    I'm at my rope's end and don't even know where else to go to read something I haven't already read or watched on youtube.

    I'd really appreciate any kind of help. Let me know if you need any more information that I haven't supplied, not sure what else to include.

    Update: on the arcade emulator, when I try to save with the Select+Rshoulder it says "core does not support save state" - what does this mean and how do I fix this issue?


  • Global Moderator

    mame4all is not a RetroArch emulator, so save/load via the Hotkey (Select) will not work.
    Use a Libretro core emulator - lr-mame2003, lr-fbneo - for arcade games and the hotkeys for save/load will work automatically. Make sure you read and understand how Arcade games work - https://retropie.org.uk/docs/Arcade/ - so you will not have problems with ROMs not working.



  • @mitu I got the same outcome using lr-mame2003 and the game (in this case, battletoads) won't even boot at all with lr-fbneo.


  • Global Moderator

    If you're using lr-mame2003, then the Hotkey shortcuts should work - what button did you configure as Hotkey when configuring the gamepad in Emulationstation ?
    As for the ROM not working with lr-fbneo - see my previous post.



  • @mitu and now its stuck on lr-fbneo and won't let me change it for some reason under which method to use for this rom. I skipped the hotkey when configuring my ps4 controller because that's what a bunch of forums and videos said to do.


  • Global Moderator

    @Known2Own said in Need help badly regarding PS4 controller:

    I skipped the hotkey when configuring my ps4 controller because that's what a bunch of forums and videos said to do.

    When you skip the hotkey, the configuration dialog will ask you if you want to use Select as the hotkey - did you choose this option ?



  • @mitu yes, i selected yes.


  • Global Moderator

    OK, so your Hotkey should be set. Are you able to access the RetroArch RGUI by using Select + X ?



  • @mitu I don't think so. Do I press select and X at the retropie menu or in-game?


  • Global Moderator

    The shortcuts are working in a game, when you start it with a lr- emulator (lr-mame2003, lr-fbneo, etc).



  • yeah still doesn't work even in-game.


  • Global Moderator

    Please add more info about your system and how it's set up - https://retropie.org.uk/forum/topic/3/read-this-first.



  • @mitu Pi Model or other hardware: 3 b+
    Power Supply used: the one that came in the starter kit. 250-V
    RetroPie Version Used (eg 3.6, 3.8.1, 4.1 - do not write latest): 4.5 rpi2_rpi3
    Built From: retropie-4.5-rpi2_rpi3 using Etcher
    USB Devices connected: keyboard (saitek eclipse II), generic mouse, ethernet cable, hdmi cable that came with kit, power supply that came with kit, ps4 controller plugged in via usb
    Controller used: ps4 controller via usb
    Error messages received: "core does not support save state"
    Log found in /dev/shm/runcommand.log (if relevant):
    Guide used: (Mention if you followed a guide): pretty much every single thing found on the net couldn't help my case.
    File: (File with issue - with FULL path)
    Emulator: (Name of emulator - if applicable):
    Attachment of config files: (PLEASE USE PASTEBIN.COM FOR LARGE LOGS)
    How to replicate the problem: try booting turtles in time smulator via mame4all and saving. it won't save no matter what. OR you can try booting battletoards via arcade and save to get the error msg.


  • Global Moderator

    @Known2Own I think the message it quite clear:

    Error messages received: "core does not support save state"
    

    Not all drivers (i.e. games) have save state support in the emulator version you're trying.
    For the record, saving/loading works fine with lr-fbneo.



  • @mitu so if the rom doesn't boot using fb-neo then there is no save function?


  • Global Moderator

    @Known2Own I'm saying that with the proper ROM, save states work in lr-fbneo for the tmnt2 arcade ROM.



  • ok cool appreciate your help.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.