Please do not post a support request without first reading and following the advice in

Waveshare Game Hat Black Screen

  • Hello, all,

    I'm fairly new to the Raspberry Pi, but have successfully built 2 Pis running RetroPie. I bought a Waveshare Game Hat recently and decided to build it today. I followed the instructions carefully, and when I turned it on, the screen displayed "No Signal." I realized that I didn't have the GPIO pins lined up properly, so I turned it off, removed the battery, removed the SD card, unplugged the Pi (3B+), and plugged it back in making sure the pins were correctly aligned this time. Then I put the battery back in (checking the polarity carefully), connected the HDMI adapter, and put the SD card back in.

    When I turned it on this time, the battery lights came on as before, so there's power running through the system somehow, but I'm getting nothing but a completely black screen. I plugged the power adapter in to see if it was a low power issue, but that made no difference. I've turned it off and on a couple of times and fiddled with the GPIO and HDMI connections, but still nothing but a black screen.

    Any ideas on what has gone wrong? Is my Game Hat itself broken somehow? Did I just corrupt the SD card by turning it off when I got the "No Signal"? Or is something else that I'm ignorant of messed up? Any help would be greatly appreciated. I've been super excited to get this thing up and running, and to say the least today has been a flop.

    Thanks in advance for your help!


  • @AnnArrogance Can't figure out how to edit a post, but I wanted to update. I found another SD card and flashed it. No dice. Then I got the Pi we use for Kodi in the living room, hooked it up to the Game Hat, tried both SD cards, and still no dice. Looks like I did something to the Game Hat itself along the way--probably to the HDMI port, I'm guessing. I've ordered a new one, but if anyone has any other ideas, I'd still love to hear them. Thanks for reading!

  • Maybe a stupid question, but have you installed the HDMI adapter that connects the Raspberry HDMI to the HDMI of the Game Hat? You probably had to remove it to install the Raspberry to the Game Hat, but after doing so you need to put it back!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.