Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Gamepad and hub not detected


  • Global Moderator

    @nielogiczny the screenshot you posted just shows some device names, not the gamepad functionality. Did you test that the gamepad is working, under Raspbian?

    In Linux, most drivers are already included with Linux kernel - Retropie has the same kernel as the Raspbian version it's based on, regardless of the Lite/DEsktop version. What versions of Raspbian/Retropie are you teating ?



  • @mitu I tested gamepad and hub fully on Windows 10 - works good. What I tested on Raspbian is just detecting devices. I have no knowledge of commands so didn't test fully on Raspbian.

    I used RetroPie v4.5.1 as well as 4.4 and Raspbian released 2019-07-10 with kernel version 4.19 from this site: https://www.raspberrypi.org/downloads/raspbian

    Gamepad can be reprogrammed or get different chip if this solve the problem.


  • Global Moderator

    @nielogiczny you can test the gamepad under Linux with the jstest command, from the command line. It should be installed on both Raspbian and Retropie. Look for its usage in the docs, should help you decide if the gamepad is functional.



  • I did jstest as you suggested @mitu - results on screenshots: https://imgur.com/a/SCgEbxG

    During jstest 2 devices were connected: Microsoft keyboard with mousepad on it and gamepad. Hub was not connected.
    What I found on the internet, there should be more results after typing jstest / dev/input/js0 and js1 but it ends here for me.

    Btw. because my Raspberry Pi board have only 1 usb input, I used Orange Pi for this test which have 3 usb inputs.

    Have you got idea what to do next?


  • Global Moderator

    @nielogiczny the command you ran didn't show if the gamepad is functional or not - the command was not found. Please use the Retropie image and test with that image, OrangePis are a different SBCc.



  • @mitu I'll look for some way. Used Orange Pi for this test because my Raspberry Pi Zero and A+ have only 1 usb input. Need keyboard and gamepad connected at the same time to make this test. Otherwise keybord doesn't work when connected through hub.



  • Update. I managed to do jstest properly on RetrorangePi and gamepad works. Every pressed button have been noticed on the screen.

    Still the problem is gamepad isn't detected on main screen after launch and communicate "no gamepad detected" appears.

    Screenshot showing test result: https://imgur.com/a/mNWTkY7



  • @nielogiczny I know it sounds simple, but have you tried holding a button on the controller at that screen to detect gamepads? as far as I can tell, nothing shows up as detected until you hold a button on one of your controllers (gamepads).



  • @Dopy25 of course :)

    Good news! I solved the problem and gamepad works now!

    I added rule into catalogue: /etc/udev/rules.d/99-gamepad.rules including this line: SUBSYSTEM=="input", ATTRS{name}=="NAME OF DEVICE", MODE="0666", ENV{ID_INPUT_JOYSTICK}="1"

    Thanks @mitu and @Dopy25 for replies. Cheers!



  • @nielogiczny Makes sense! I had to do that with the 8-bitdo SNES Bluetooth controller. The setup script had it as an option. Before that, only one or 2 of the key presses would do anything, and it registered as a keyboard when it did.

    Glad you got it working!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.