Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Ports won't launch from Emulation Station



  • Pi Model or other hardware: Raspberry Pi 3B+
    Power Supply used: Official charger from starter kit
    RetroPie Version Used: 4.5.1
    Built From: retropie-4.5.1-rpi2_rpi3.img.gz (from RetroPie.org.uk)
    USB Devices connected: Logitech Keyboard/Mouse dongle
    Controller used: PS3 Dual Shock
    Error messages received: None
    Log found in /dev/shm/runcommand.log (if relevant): https://pastebin.com/RQ59bWZm
    Guide used: N/A
    File: Presumably /home/pi/RetroPie/roms/ports/Desktop.sh and /home/pi/RetroPie/roms/ports/Kodi.sh
    Emulator: Ports (Desktop and Kodi)
    Attachment of config files: N/A
    How to replicate the problem: Select Kodi or Desktop from the Ports section of the menu

    This is an almost vanilla installation of RetroPie. What I've done so far is:

    • Added some roms to other console folders
    • Installed Pixel desktop via Configuration / Tools > Raspbiantools > Install Pixel Desktop Environment
    • Installed Kodi via Manage Packages > Manage Optional packages > Kodi > Install from binary
    • Added the following to es_systems.cfg because it didn't automatically do it when I installed the two above packages:
      <system>
        <name>ports</name>
        <fullname>Ports</fullname>
        <path>/home/pi/RetroPie/roms/ports</path>
        <extension>.sh .SH</extension>
        <command>/opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ psx %ROM%</command>
        <platform>ports</platform>
        <theme>ports</theme>
      </system>
    

    When I try run either the Desktop or Kodi option from the EmulationStation menu, after a few seconds it just drops back to the menu. No error is shown in this interface.

    I also read that there is a Kodi error file in the home directory but I don't see one of those available.

    Thanks in advance for any advice.



  • @LeonardChallis
    First of all it looks like your es_systems.cfg isn't configured correctly.

    There's a couple locations for es_systems.cfg
    https://retropie.org.uk/docs/EmulationStation/#editing-es-configs

    The original location which is re-written everytime you update RetroPie and install new emulators:
    /etc/emulationstation/es_systems.cfg

    And your custom one that overrides the original if it excites and is not automatically re-written by RetroPie:
    ~/.emulationstation/es_systems.cfg (which is a symlink to /opt/retropie/configs/all/emulationstation/es_systems.cfg)

    You could look for Kodi and Desktop configuration in /etc/emulationstation/es_systems.cfg and manually add those changes to ~/.emulationstation/es_systems.cfg

    Note: I'm not at my RetroPie to look to see what the correct settings should be.



  • Okay, here's what I've got in es_systems.cfg

      <system>
        <name>ports</name>
        <fullname>Ports</fullname>
        <path>/home/pi/RetroPie/roms/ports</path>
        <extension>.sh .SH</extension>
        <command>bash %ROM%</command>
        <platform>pc</platform>
        <theme>ports</theme>
      </system>
    

    And then put this in/home/pi/RetroPie/roms/ports/Kodi.sh

    #!/bin/bash
    "/opt/retropie/supplementary/runcommand/runcommand.sh" 0 _PORT_ "kodi" ""
    


Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.