Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Hello. Before anything, I should note that I'm aware of the existing Bluetooth issues in the 4.19.42 kernel and have used the scripts based on this thread. I'm trying to pair a dualshock 3 controller to an Orico BTA-403 bluetooth adapter. I get as far as picking the security mode and trying either "DisplayYesNo" and "KeyboardDisplay" but bluez fails on either with an AuthenticationFailed message:

    [bluetooth]# info 44:BD:8B:CE:EE:61
    Device 44:BD:8B:CE:EE:61
            Alias: 44-BD-8B-CE-EE-61
            Paired: no
            Trusted: no
            Blocked: no
            Connected: no
            LegacyPairing: no
            ManufacturerData Key: 0x004c
            ManufacturerData Value: 0x10
            ManufacturerData Value: 0x05
            ManufacturerData Value: 0x1e
            ManufacturerData Value: 0x1c
            ManufacturerData Value: 0xa2
            ManufacturerData Value: 0xe5
            ManufacturerData Value: 0xb7
    
    [bluetooth]# pair 44:BD:8B:CE:EE:61
    Attempting to pair with 44:BD:8B:CE:EE:61
    [CHG] Device 44:BD:8B:CE:EE:61 Connected: yes
    Failed to pair: org.bluez.Error.AuthenticationFailed
    [CHG] Device 44:BD:8B:CE:EE:61 ServicesResolved: no
    [CHG] Device 44:BD:8B:CE:EE:61 Connected: no
    [DEL] Device 44:BD:8B:CE:EE:61 44-BD-8B-CE-EE-61
    

    Pi Model: Pi 1 B+
    Power supply: Canakit 3-Amp
    RetroPie version: 4.14.98+ (not sure about that one but the output of uname -a is Linux retropie 4.14.98+ #1200 Tue Feb 12 20:11:02 GMT 2019 armv6l GNU/Linux)
    Built from: https://github.com/RetroPie/RetroPie-Setup/releases/download/4.5.1/retropie-4.5.1-rpi1_zero.img.gz
    USB devices connected:

    Bus 001 Device 005: ID 054c:0268 Sony Corp. Batoh Device / PlayStation 3 Controller
    Bus 001 Device 004: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    

    Controller used: dualshock 3
    dpkg output: https://pastebin.com/TZXswFUP

    I found a couple of errors from the bluetooth service, not sure if it's relevant:

    pi@retropie:~/RetroPie-Setup $ service bluetooth status
    ● bluetooth.service - Bluetooth service
       Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset
       Active: active (running) since Fri 2019-08-02 02:46:33 PDT; 19h ago
         Docs: man:bluetoothd(8)
     Main PID: 355 (bluetoothd)
       Status: "Running"
       CGroup: /system.slice/bluetooth.service
               └─355 /usr/lib/bluetooth/bluetoothd
    
    Aug 02 02:46:33 retropie systemd[1]: Starting Bluetooth service...
    Aug 02 02:46:33 retropie bluetoothd[355]: Bluetooth daemon 5.43
    Aug 02 02:46:33 retropie systemd[1]: Started Bluetooth service.
    Aug 02 02:46:33 retropie bluetoothd[355]: Starting SDP server
    Aug 02 02:46:33 retropie bluetoothd[355]: Bluetooth management interface 1.14 in
    Aug 02 02:46:33 retropie bluetoothd[355]: Failed to obtain handles for "Service
    Aug 02 02:46:33 retropie bluetoothd[355]: Sap driver initialization failed.
    Aug 02 02:46:33 retropie bluetoothd[355]: sap-server: Operation not permitted (1
    

    dmesg is here, in case there's something useful in there.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.