Please do not post a support request without first reading and following the advice in
  • Banned

    When I run DOS games in dosbox, they run perfectly but get stretched out to fill the full screen. If I run them in lr-dosbox instead, the aspect ratio is correct but they slow to a crawl. I just spent four extremely frustrating hours trying every imaginable permutation of display settings in the (non-lr) dosbox config file, without success.

    The config file says "What resolution to use for fullscreen: original, desktop or a fixed size (e.g. 1024x768). Using your monitor's native resolution with aspect=true might give the best results. If you end up with small window on a large screen, try an output different from surface."

    This is correct. The only thing that gives me the right aspect ratio is using my monitor's native res of 1920x1080. But that gives me a screen the size of a postage stamp. I can bump it up a bit by setting scaler=normal3x, without any perceptible drop in performance, but it's still only using about a third of the screen area.

    So as suggested I tried switching to output=overlay (which appears to be the only available option other than surface). Now I get a full-size display in the correct aspect ratio, but it's shoved over to the far left of the screen and again we're down to an absolutely unplayable crawl.

    (If I run it in windowed mode, then even with window resolution set to 1920x1080 we're back to Stretch-O-Vision.)

    Surely just correcting the aspect ratio can't be turning the emulation from full speed to about 2fps? Has anyone solved it?

  • Banned

    @SpudsMcToole I guess it can be...

  • Banned

    The thing that's really driving me batty is that in 1920x1080 the screen is the correct shape, just too small. But if I set it to another resolution that has THE EXACT SAME ASPECT RATIO (eg 1600x900), we're back to Stretch-O-Vision again. WTF?

  • Global Moderator

    @SpudsMcToole Can you post your complete .conf file ? Use for it.

  • Banned

  • @SpudsMcToole In my first experiences with DOSBox, I found that the RetroPie version behaved differently to the desktop version when it came to the display settings. Consequently, it's not advisable to edit the sections of dosbox-SVN.conf that relate to display and use the defaults instead.

    Here is a copy of mine:

    Running mine and your copies through Diff Checker, I notice that lines 24 to 27 and 59 differ. I recall playing with these lines in the past and it did not have the desired effect so I kept to the defaults. For example, if I setaspect to true, then I get a mouse cursor permanently in the top left hand corner.

    I tried your settings and I got DOSBox running in a small screen at the centre of my display, though the aspect ratio appeared correct. Could you try restoring these lines to defaults as in my copy?

    I also notice that the core (line 81) is set to auto. In my config file, it is set to dynamic which I believe is required to optimise performance on the pi. The setting is, in fact, made in the DOSBox scriptmodule in this line.

  • Banned

    @dudleydes Weird - the mouse pointer appearing is usually the result of running with fullscreen set to false.

    With your CONF file I still get a stretched screen, not quite the width or height of the monitor.

    HOWEVER, if I change the aspect line to true, it works! And if I set fullscreen to true the mouse pointer disappears as well. I have no idea how you did it, but problem solved! Thanks :)

  • Banned

    @SpudsMcToole I've been using ChampGames' arcade clones to test this, so as a small token of gratitude here are the mockup game boxes I've made for them :)









Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.