Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retropie Not Recognizing my SNES30 Pro+ Controllers



  • Raspberry PI 3B
    v4.5.1 (Just updated through the system menu to whatever the current is if not 4.5.1)
    Raspberry Pi Official AC Adapter
    400GB Sandisc Card
    2 SNES30 PRO+ Controllers (USB C)
    1 SNES30 Controller (USB Micro)

    I recently bought two SNES30 PRO+ Controllers because they looked like the perfect retro controller, and by all accounts and reviews, I heard they are.
    (Controller seen here https://www.amazon.com/8Bitdo-Sn30-Pro-Bluetooth-Gamepad-Sn/dp/B07T8JKVNT/ref=sr_1_3?keywords=snes30+pro%2B&qid=1569019522&sr=8-3 )

    I plugged them in via USB, just like I do my SNES30 controller, and while it system says it recognizes the 2 controllers, I cannot configure them. When I go to set the buttons, I hold down A or any other button and the input is never detected.

    I don't use Blutooth with these devices, and they work fine over USB for PC, so I am curious if the drivers are missing, or did I screw something up?

    (The controller may need an update, that HAS happened before)



  • @Jiryn Does the pair/usable mode have to be selected for usb? I have not tried through USB yet as my Pi is always too far away. I have the SN30 Pro i use over bluetooth (with ghost inputs in ES on a 3B+).



  • @KN4THX
    Might have something to do with the "Modes" the website talks about,
    I've been using the controllers for my Switch, but it seems i have to set it for different game play modes/settings.

    I am guessing Windows mode is what I should use?
    (It has 4 modes, Switch, Android, Windows, and Mac)

    (Off topic, I am horrible at pairing Blutooth equipment with the Pi/Blue Config screen, it detects the controllers but every config fails)



  • @KN4THX Found the problem!
    You have to switch modes while NOT connected via USB.
    The mode cannot be switched while plugged in!



  • @Jiryn For the Pi it is the Switch Mode. Start + Y. I tried using a different mode today to improve the ghost input situation but then some buttons are not detected. I know on my debian laptop I have to use another mode which is strange because they are both linux. Again, all of my experience is with bluetooth. I have been curious to see if the mode matters in USB.



  • @Jiryn Glad you got it figured out and even beat my slow typing :) I wasn't sure about that but now I know!



  • @KN4THX
    I got both Android and Microsoft mode detected when wired.
    Android detects as a PS Controller
    Microsoft as a 360 controller
    it does NOT like Switch Mode

    Odd question, my Retropie's sound for PS1 games are really, really low and not sure why.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.