Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Hi everyone. First time poster, and have been experiencing an issue with my Raspberry Pi 3b+. I have RetroPie installed and probably over 1,000 roms loaded. However, any time I play ANY of the games (nes, snes, n64, even sega) it lags bad, and the audio is really weird. Almost like the audio is lagged too.

    I have overclocked to these settings:

    arm_freq=1400
    core_freq=580
    gpu_freq=525
    v3d_freq=400
    sdram_freq=550
    over_voltage=1
    temp_soft_limit=70

    I have my GPU memory set to 512.

    video_threaded = true
    video_smooth = false
    audio_driver = alsathread
    rewind_enable = false
    video_hard_sync = true
    video_hard_sync_frames = 3

    I started out on a Dell 27" monitor, and then switched to my 32in TV, and have the same issue on both. I have also tried putting the TV in "Game mode" and still have the issue.

    I also get this error when switching screens (not sure if it's related or not) in RetroPie that says:
    lv10 :: VolumeControl :: init () Failed to find Mixer elements.

    RetroPie is running on top of Raspbian and everything is up-to-date.

    Any one that would have any ideas, I would really appreciate it!

    Thanks!


  • Does the Dell 27" monitor have built in speakers?

    On the 32" TV you could also turn off all audio filters.

    You might experiment with:

    video_hard_sync = "false"
    video_hard_sync_frames = "0"

    Also try (or this might make it worse lol):
    audio_latency = set to as low as you can set it without hearing audio crackle


  • @squeechums try not overclocking the pi and see if that fixes the issue with the older systems. It’s possible that that overclock is running too hot and causing the cpu to run at half speed. Or your pi just my be unstable at the higher clocks.


  • @lostless I just now set up the overclock. The issue was occurring before I did that ☹️


  • You're not suppose to fool around with the video settings. The settings are already optimized. Revert all your changes and try again. If they were already like that, it means you probably used a 3rd party image and they are not supported.

  • Global Moderator

    Use the default retroarch.cfg - leave aside all the hard sync settings (I don't think they're relevant for the Pi's GPU) and the audio settings. Also, a GPU mem of 256 is more than enough for most emulators, so I don't see any point in upping it to 512.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.