Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Solarus Engine Games not installing properly



  • I install the Solarus Engine from Retropie Setup. They appear in the menu. But when I try to run them they all act like they're starting up, then they quit. So I check /dev/shm/runcommand.log it says "/opt/retropie/ports/solarus/bin/solarus_run not found". So I look in /opt/retropie/ports/solarus/bin/ and I see there's a solarus-run.

    Well, that might explain it.

    I decide instead of editing 3 files I'd just make a copy of solarus_run called solarus_run. Figure that'll satisfy the scripts. But now when I try to trun it, it quits and runcommand.log says "no quest was found in the directory /opt/retropie/ports/solarus/share/solarus/zsdx". So I check and... yup, there's nothing in /opt/retropie/ports/solarus/share at all really.

    Raspberry PIe 3, latest version of RetroPie downloaded just last week. Powered through a USB charger, probably underpowered, but I don't think that's this problem. Willing to accept that I might be wrong, though.


  • Global Moderator

    @3dpprofessor Did you install from source or from binary ? Update your RetroPie-Setup script and then re-install the Solarus Engine again.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.