Please do not post a support request without first reading and following the advice in

USB Controllers

  • Good Evening Gamers,

    I hope everybody had an awesome day.

    The issue I am having is with any controller. I can take any controller SNES to PS4 and test them on one system which works unplug them and test them on an newly imaged system and run into issues. For PS4 for example when mapping the controller the right analog "left" does not work. I have to skip mapping that in order to anywhere else. This happens on ost new systems especially when trying to play systems like dreamcast. when this happens Dreamcast does not recognize the controllers at all. I tried remapping for the system and with specific emulators. I also tried re imaging the SD card. I also checked out the config files and I didn't notice any differences between two different machines where 1 does and the other does not work. I have only been seeing this issue on cards that are 256GB. I am working with a 256GB class 10 sd card, RetroPie 4.5.1, and a raspberry Pi 3 B +.

    Any and all help is greatly appreciated.

    Thank you for your time

  • Global Moderator

    I don't think the SD card capacity has any role in this, more likely the emulator versions are different on the systems you're testing. Reicast seems to have issues in the latest versions with controller inputs - configurations that worked before are not working at all right now.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.