Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • I'm trying to install RetroPie in a Debian Stretch container on my Chromebook and I get the following error with the libc6 version:

    paul@penguin:~/RetroPie-Setup$ sudo ./retropie_setup.sh
    Did not find needed package(s): gcc g++ build-essential python-pyudev. I am trying to install them now.
    
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     build-essential : Depends: libc6-dev but it is not going to be installed or
                                libc-dev
     g++ : Depends: g++-6 (>= 6.3.0-9~) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    Unable to install packages required by /home/paul/RetroPie-Setup/retropie_packages.sh - Could not install package(s): gcc g++ build-essential python-pyudev.
    

    The current version in Stretch is 2.24-11+deb9u4. It looks like I need 2.29-2 however, I would need to go to testing branch. Installing only libc6 from here is likely to cause other problems, being relied upon by many other packages in the system.

    Is there any way to install without moving to testing branch fully?

  • Global Moderator

    @paulmorabi That's not really a RetroPie problem, but a distribution package management issue. It looks like you can't install gcc - which is the basic C/C++ compiler collection for GNU/Linux.
    What repositories are enabled in the container you're trying to run ?


  • Yes, I know it's an issue with the OS/Debian rather than Retro Pie so posting here to see if anyone else has managed to get it installed. My /etc/apt/sources.list is:

    deb https://deb.debian.org/debian stretch main
    deb https://deb.debian.org/debian-security stretch/updates main
    
    deb http://deb.debian.org/debian stretch contrib non-free
    deb http://security.debian.org/ stretch/updates contrib non-free
    

    As I said, the problem seems to be that Debian Stretch doesn't support the libc6 version installed. Switching to test or unstable might work but as libc6 is a core library, it could break other things so from a quick search, this is normally not advisable. I actually only tried because the site said it can work on Debian based distro's.

  • Global Moderator

    @paulmorabi Debian Buster is the current Debian stable release, not Stretch.


  • The default Chrome crostini Linux container is still using Stretch. It will be upgraded to buster in the next 1-2 releases of ChromeOS.

    In any case, current stable/Buster has libc6 version as 2.28-10 and RetroPie requires 2.29 from memory?

  • Global Moderator

    RetroPie doesn't require a specific libc version, the error you're getting is when you try to install build-essential, which is a basic package collection on a Debian system.
    I just installed RetroPie on a stock Debian Buster system and there is no problem installing or running it. RetroPie also works on Ubuntu 18.04 (or other spin-offs like Xubuntu/Lubuntu/Mint), so it's not a libc compatibility issue here.


  • Based on your reply, I deleted and recreated the container and installed RetroPie immediately afterwards. It worked! It's installing now. I'm guessing there was some other package conflict with another app installed. Thank you for your help.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.