Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Metadata Not Saving



  • Hello, I am trying to save various metadata through the Emulationstation menus by selecting a game and "edit this game's metadata." When I try to save a new marquee file, it shows up initially, but then upon resetting it reverts back to what it was before I saved the new one. Is there some permission issue happening? I also am trying to scrape a new game for SNES but it is giving me the "disk full?" error. This could be related?

    Rpi 3b+ and latest build of Retropie as of today (just updated all)


  • Global Moderator

    @GreenHawk84 said in Metadata Not Saving:

    I also am trying to scrape a new game for SNES but it is giving me the "disk full?"

    The disk full ? might be an indication - though this error message appears when the scraper can't process or save the image it downloads, so it doesn't necessarily means the disk is full (could be a malformed image, a permission issue). But you should check if you still have space available nevertheless.

    Can you check the Emulationstation log file for any errors ? Should be easy to access via file shares at \\retropie\configs\all\emulationstation\es_log.txt.



  • @mitu es_log.txt

    /dev/root 29846M 9883M 18713M 35% /
    devtmpfs 370M 0M 370M 0% /dev
    tmpfs 375M 0M 375M 0% /dev/shm
    tmpfs 375M 10M 365M 3% /run
    tmpfs 5M 1M 5M 1% /run/lock
    tmpfs 375M 0M 375M 0% /sys/fs/cgroup
    /dev/mmcblk0p1 57M 22M 36M 39% /boot
    tmpfs 75M 0M 75M 0% /run/user/1000
    tmpfs 75M 0M 75M 0% /run/user/0

    Ok, I got the SNES scrape to work, as well as Neo-Geo, due to having [root] as the user permissions and not [pi] for the downloaded_images files. But I still cannot save a new marquee to a game in arcade, even though arcade has [pi] user set.



  • Found another permission change needed to the gamelist.xml files. Damn, how did all this need changing? Anyway, I guess I fixed it! Please do still look at my error log to see if anything else needs fixin!


  • Global Moderator

    @GreenHawk84 There doesn't seem to be other error in the log file. Glad you sorted it out, these kind of errors are almost every time a permission error.



  • @mitu you are a great help for this community, thanks.



  • @mitu odd issue again.. when I updated Retropie it changed all the permissions back to Pi [1000] and now I am getting a message when trying to change back to root:
    WINscp Set Ownership.jpg


  • Global Moderator

    @GreenHawk84 The gamelist.xml files are not owned by root, they should be owned by the pi user - why are you trying to change their permissions/owner ?



  • Because they are not saving metadata, I get the permissions error which I solved before by changing permissions.


  • Global Moderator

    I'm a bit confused - the right permissions for the gamelists are to be owned by the user pi. If you change the file to be owned by root, then Emulationstation (which runs as user pi) will not be able to save any metadata (writing back the gamelist.xml file).

    Make sure the files are owned by the user pi, then try again to see if the metadata is saved. If it's not, show a screenshot of the file's permissions. Also, make sure you didn't accidentally disabled saving the metadata on exit from the Emulationstation settings.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.