Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Juyao Dual Arcade 2 player on Ubuntu


  • Global Moderator

    Usually, if there's something needing admin rights - like loading/unloading module - it'e enough to add sudo before the command to run it as admin.

    I don't have any more ideas what to check.
    You can manually unload the driver (sudo rmmod usbhid), then load it with the quirks parameter set

    sudo modprobe usbhid quirks=0x0314:0x0328:0x040
    

    then check again if your encoder is detected as 2 gamepads.



  • @mitu said in Juyao Dual Arcade 2 player on Ubuntu:

    sudo modprobe usbhid quirks=0x0314:0x0328:0x040

    you sire... are my new GOD!!... thank you so,so much... this DID the trick... it shows as 2 players AND no more spastic movement in menu! I need to get roms on there and see if all still works.. but i will let you know!

    thanks a million times


  • Global Moderator

    .. this DID the trick ..

    The command should be the equivalent of setting the module options (usbhid.quirks) with the .conf file, so I don't understand why it's not working via configuration, but it works from the command line (?).



  • @mitu yeah it does, but does this mean i have to run it each time? Because that wouldn't be the best lol

    Isn't the problem the line I added?
    options usbhid quirks=0x0314:0x032..... etc
    Because via the command line I did not use the 'options' text


  • Global Moderator

    @Dennis said in Juyao Dual Arcade 2 player on Ubuntu:

    Because via the command line I did not use the 'options' text

    The syntax is a bit different between the .conf file and the command line options, but the effect should be similar - I've tested it on an Ubuntu 18.04 installation, just like yours.

    Can you double check if the options file is the correct path (file is in /etc/modprobe.d) and extension (.conf) ? If the options file is not correctly created, then the options won't apply automatically. If that's not the case, then you'll probably need to find a way to run the commands I posted earlier on each boot.



  • @mitu yeah just checked and the file is 100% there.... it is read only btw and user is root... is that the problem.. i even tried adding another conf file without the rp- part.... i dont understand :(

    Can't I add the line to another file and if yes, do you know how? Could it be the retropie install way I tried? See the url above which steps i used


  • Global Moderator

    @Dennis said in Juyao Dual Arcade 2 player on Ubuntu:

    Can't I add the line to another file and if yes, do you know how? Could it be the retropie install way I tried?

    No, the RetroPie installation doesn't affect the this part. Now that I'm thinking about it, there is another way - similar to how it's done for the PI: add the arguments to the boot loader (grub). See how it's done here - add the usbhid.quirks=0x16c0:0x05e1:0x040 fragment to GRUB_CMDLINE_LINUX_DEFAULT then run update-grub and reboot.



  • @mitu this totally worked!!! thanks!!! b/c of new years eve and all I dont have time now to test a ROM and see if the controls work... on my friends Pi the controls worked in the menu but not in game... I will let you know!

    thanks again so much and have a save and happy new year



  • So, both controls are recognized! But now the controls do not work in game for player 1... in the menu I can use all the buttons but when starting a game only the right side of the arcade controls, so player 2 work.... nothing on the left arcade buttons work... also I couldnt exit out of the game for some reason... very weird.. any idea?



  • Got of working via the retroarch mania thanks again for the amazing help



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.