Please do not post a support request without first reading and following the advice in

  • Hi all,

    I first posted about this last August when I built my Picade - and I have yet to solve it.

    It's driving me absolutely crazy. I would really appreciate any insight. Read a lot of posts, tried a lot of things, got nowhere.


    1. Out of the box - RetroPie's default controller mappings don't work for Defender (and I presume games like it) with lr-mame2003. No matter what I try I can't fix them.

    To reproduce - I install RetroPie on a fresh SD card. I curl the Picade-HAT setup. I boot to EmulationStation and I map
    ABXYL1R1 to the 6 buttons on the console. I map L2 and R2 to the side buttons, and Select and Start to the front buttons.

    Start up Defender.

    X button thrusts AND fires
    Y thrusts
    A button fires
    B button teleports AND reverses ship direction

    Totally screwy.

    Hit Tab to check MAME keybindings - they are as follows

    Fire is LCTRL or RetroPad1 B or RetroMouse1 Left Click
    Thrust is LALT or RetroPad1 Y
    Smart Bomb is SPACE or RetroPad1 X or RetroMouse1 Right Click
    Hyperspace is LSHIFT or RetroPad1 A
    Reverse is z or RetroPad1 L

    At this point I have half a mind to clear the MAME keybindings and start again EXCEPT
    Problem 2) I can't delete any keybindings. Not using ESC ESC, not using Delete.

    I don't know if this would work even if I could do it.

    I've wondered whether setting the Picade into Controller mode (I believe it emulates keyboard by default) would help, as in this thread. But despite updating the firmware I haven't got enough info to communicate via serial port to change the settings.

    I tried doing the serial comms using the info on this page but it's not working. And again I don't know whether it will help anyway.

    If anyone could throw any light on this I'd be really grateful!

    Possibly confusing fact
    I don't have /dev/ttyACM0
    Closest thing I have is /dev/ttyAMA0

    Happy new year!!!



    Old post:

  • Banned

    to clear a binding press left then left again when it asks for and input

  • @grant2258 Thanks, but that doesn't work - it just adds two LEFT bindings to whatever I'm binding.


    To clear Mame mappings in lr-mame2003 on a Picade, with a USB keyboard connected:

    Use the up and down arrows to select the control you want to clear.
    Press Backspace.
    Press Enter.
    Press your button.


  • Banned

    Let me try explain this to you for the keyboard the double inputs come from the keyboard mapped to the retropad and keyboard. Its an RA think there is two ways to deal with this.

    One is to use game focus mode this disables retropad and hotkey binds so you can use the full keyboard and retropads with no issues.

    The other option is that was added is option for setting accepting only on input type keyboard or retropad this effectively only accepts one input device you can choose between retropad and keyboard.

  • @grant2258 Hi Grant - yes I think I've realised that this is the problem. The default RetroArch setup creates a virtual gamepad and binds both virtual gamepad and keyboard. I think the problem with Defender is that these mappings overlap - so the virtual gamepad is triggering as well as producing a keypress, and these are both bound to different things (eg thrust AND fire).

    Thanks for your help!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.