Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Can’t connect to my pi anymore



  • So,
    I’ve been connected to my pi with the same computer with no issues.

    I recently wiped my computer and reinstalled windows 10.

    Initially I typed in my IP address as before and got a credentialing screen

    I typed
    UN: pi
    Password: raspberry

    Now it’s saying it can’t connect.

    Did I fat finger the password or something?



  • @tackett1980

    Ok, so I just pinged it in a command prompt using the exact same IP address as what I’m typing and it still isn’t working

    Ping 192.168.x.xxx
    Reply

    Go to windows
    \192.168.x.xxx

    Windows can not connect.



  • Ok, so I went through program services and smb was disabled. So I enabled it, rebooted and now I can actually see //RETROPIE in the network menu, but when I click it, I still get the same error message.

    I get the feeling that it’s trying to connect to the pi with fat fingered credentials. Does anyone know how to reinput the un and password? I would imagine if that was the case the stupid thing would just say “incorrect UN or password”.



  • Another update.

    I found the windows credentialing section and fixed that. No dice.

    I installed winscp and I can access it with that....

    Go to windows and still does not do it.


  • Global Moderator

    What edition of Windows are you using ? We've seen this problem with End/Education editions, where guest browsing for file shares is disabled by default.



  • @mitu

    Windows 10 home.



  • Ok this is ticking me off.

    I want to run skraper but I can’t direct to my freaking roms folder because windows won’t access it.

    Here is exactly what I did and exactly what’s going on.

    I have a 128gig card
    I built a system for a friend utilizing a 64 gig card
    I liked the build I did for him better than the one I did for myself.
    I made a backup of the 64 gig sd card
    Formatted my 128
    Wrote his 64gig image onto my 128
    Expanded the file system.
    I also formatted my PC and reinstalled windows 10 home. Which was working previously just slow.

    Before I did this I was able to access the pi from both wired and wireless networks.

    Now whenever I try to access the pi through windows only I get this error:
    If I type IP address directly
    “Windows can not access \192.168.x.xx”
    Same if I type \RETROPIE
    “Windows can not access \RETROPIE”

    I can see the stupid thing in my network connections list.
    Network

    RETROPIE

    I click it and I still get the same error code.

    I can access it by winscp
    I can ping it in cmd prompt.

    I’d like to skrape my stuff with skraper for windows but it needs me to direct it to the roms folder which windows will not allow me to do.

    Any suggestions would be fantastic. Thanks for the help already.


  • Global Moderator

    @tackett1980 said in Can’t connect to my pi anymore:

    “Windows can not access \192.168.x.xx”
    Same if I type \RETROPIE
    “Windows can not access \RETROPIE”

    Shouldn't it be \\retropie or \\192.168.x.yz (two backslashes) ?



  • @mitu

    Yeah that’s what I meant. I’m not sure why my phone won’t let me type two backslashes.

    I have this problem on a Windows 10 forum still having no luck.


  • Global Moderator

    Well, what you can do is copy the ROMs folders locally and point Skraper to them (entering a bogus folder for the configs share it asks). I use Skraper like this on Windows, without any connection to the Pi, and after scraping I just copy over the media folder and the resulting gamelist.xml file.



  • @mitu

    Holy crap your a genius.

    Why didn’t I think of that! I’m so stupid.



  • Have you tried enabling SMB 1.0 support through Windows features?

    If I recall, Windows 10 disables SMB1.0 by default and it may be that the pi is set to use 1.0 and that could keep you from connecting. Control Panel >> Programs and Features >> Turn Windows features on or off. Look for SMB 1.0/CIFS file sharing support.


  • Global Moderator

    @YFZdude The Pi can talk SMB2 and SMB3 fine - so it's not the PI's SMB dialect that's the problem. SMB1 was disabled for security reasons and it should stay that way.



  • @YFZdude

    Yes I tried turning it on.

    Really whatever I do makes no difference. I think it’s just something screwy in windows, I hate windows.

    Scraping the way previously described worked perfectly, thank you as usual mitu.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.